powered by Jive Software

SSO Problems

I have setup SSO on my box according to http://www.igniterealtime.org/community/docs/DOC-1362. The first time I did it I put the code in the wrong place in the openfire.xml file and screwed up the server (glad it isn’t in production). After I fixed that problem I started getting the following error.

Openfire 3.6.4 [Sep 8, 2009 8:44:14 AM]

Admin console listening at https://us-pbl-v-chat01:9091

Starting Client Control Plugin

Starting Monitoring Plugin

Debug is true storeKey true useTicketCache false useKeyTab true doNotPrompt true ticketCache is null isInitiator true KeyTab is C:/Program Files/Openfire/resources/xmpp.keytab refreshKrb5Config is false principal is xmpp/us-pbl-v-chat01.corp.rms.com@CORP.RMS.COM tryFirstPass is false useFirstPass is false storePass is false clearPass is false

principal’s key obtained from the keytab

Acquire TGT using AS Exchange

[Krb5LoginModule] authentication failed

adc1.corp.rms.com

If I took the code out of the openfire.xml config SSO worked fine. I decided to go back through the documentation and redo everything to make sure I did it properly. Last night after I went through the process everything worked fine. I went home and came back this morning and I get the same error!

What could be causing this?