Start Openfire 3.6.3 as a service on Windows Server 2003

I’ve got it installed as a service on my 2K3 machine, but every time I start the service, it immediatly stops with no errors (other than “Some services stop automatically if they have no work to do…” Used the RK to install as a service, and that went fine. Tried changing logon to the an account on server that is admin with AD priviledges (and the Openfire admin account), and even the domain admin account. Also tried using the local sys account and allowing interaction with desktop. No Joy.

Am I missing something. Not a whole lot of info to be found on how to install openfire as a service that I could find. Any and all help would be appreciated.



What do you mean by RK? Did you follow the instructions in the install documents for openfire. They provide specifics on how to install the service correctly. guide.html

What Todd said… RK = Resource Kit, and that probably corrupted the ability to use the following commands to install the service.

Windows Service

If you’re running Openfire on Windows, you will likely want to run Openfire as a standard Windows service after initial setup. If you used the Windows installer, a openfire-service.exe file will be in the bin directory of the installation. You can use this executable to install and control the Openfire service.

From a console window, you can run the following commands:

  • openfire-service /install – installs the service.
  • openfire-service /uninstall – uninstalls the service.
  • openfire-service /start – starts the service
  • openfire-service /stop – stops the service.

Any solutions? I am fighting the same battle.

Openfire has its own process to install a service. No addditional tools needed. See the posts above. Follow the install directions for openfire.

I have followed the instructions, and when I start the openfire service via the command line nothing happens. I had read a post stating that if you left it for 50 minutes it would start but it never did for me. I have started the service via net start and through the gui services.msc with no luck. When I start it via the gui I get an error stating this:


The Openfire service on [SERVER] started and then stopped. Some services stop automatically if they have no work to do, for example, the Performance Logs and Alerts service.


I am able to use the Windows gui for Openfire and start the openfired.exe and connect with a client fine and this works for a temporary solution but I really want it to run as a service.

I’m with Openfire 3.7.0 and on Win2k08 Server x64 and also openfire doesn’t work as a service, the service starts and everything but no client can connect to the openfire server…

Anyone have a solution for this??