Starting with Asterisk-IM... I need some Help

Hi Everybody !!!

Im trying to use Asterisk-IM with my Wildfire server but Im having some problems, first at all here is the information about my servers and versions,

OS: Fedora Core 5

Wildfire: 3.10.0 Beta 2

Asterisk-IM plugin: version 1.2.0 Beta 2

Asterisk Server:

Wildfire is working fine in my LAN using spark as client, I’'ve start asterisk using:

“bash> asterisk start”

and then i use:

“bash> asterisk -r”

to connect to the server, everything seems to be fine at this point, then reading some post at the forum y edited my asterisk’'s manager.conf file to allow the connection of wildfire to asterisk like this:


enabled = yes

port = 5038

bindaddr =

displayconnects = yes

secret = my_password





read = system,call,log,verbose,command,agent,user

write = system,call,log,verbose,command,agent,use


And disconnect from asterisk and restart the service. After this, I try to register my asterisk server in the asterisk-IM control panel like this:

Server Name: localhost

Server Address: 10.x.x.x (the same that is in the managers.conf)

port: 5038

username: my_username

password: my_password

so when i click on “create server” button, wildfire shows me a message like “server created sucesfully” but it doesn’‘t appears in the list of registred servers. What im doing wrong?, there is something that im not doing?.. I’'ve even disabled the firewall and SElinux but still not working.

Can you helpme please

Greeting from Mexico !!!

By the way… sorry about my English

Message was edited by: rootusr

Can you check your log file for any exceptions? Also which DB are you using?



Hi Alex Thank you for responding

I’‘ve checked my error.log file and seems to be an exception like "table phoneServer doesn’'t exist" or something like that, im sorry but I have not acces to the log file rigth now because im in home.

Im using a MySQL database installed according to the online docuementation and there are some tables with the prefix “phone” but nothig related with server. I hope you can help me, if you need more information about my configuration or servers please let me know

Thank you !!!

If you haven’'t downloaded the latest versions of Wildfire yet, you will need to run the database updates manually. As there was a bug in some previous versions of Wildfire that prevented plugin updates from being run. So, if you can update to the latest version of Wildfire then do that, otherwise you will need to run the updates manually.



I just see that is a new version of the wildfire’‘s beta , I’'ll try it next monday and let you know how did it work, Thank you !!!

The new beta version of wildfire should not need any manual updates of the database rigth?


That is correct.


Hi Alex !!! (And everybody)

It works !! I installed the new wildfire’‘s beta version and my asterisk phone server is now registered in wildfire admin console, however, I’'ve could not make a call using spark yet, I have read in the forum how to do it but it is not working for me yet, I hope that you can help me, here is the infomation:

my asterisk server is in the same pc that my wildfire server and im triying to make a call between two clients using spark, this clients are in two diferents pc’'s

The information of my asterisk’'s manager.conf file is:

enabled = yes

port = 5038

bindaddr =

displayconnects = yes

secret = my_pass





read = system,call,log,verbose,command,agent,user

write = system,call,log,verbose,command,agent,use

my sip.conf file is:




























my extensions.conf file is:




My asterisk server registration data in the wildfire admin console is:

server name: localhost

server address: 10.x.x.x


username: my_user

password: my_pass

so, what should i use in the Phone Mappings form to make a call from the user1 to user2 using spark?, the fields requeired in the form are:




caller ID

primary: yes/no

what else sould I configure? im really really confused about this part.

Thank you, and if you need more information about my configuration please let me know

Have you configured your sip.conf?

"Each SIP client that connects to Asterisk needs a definition in SIP.CONF. "

Hi Alex

yes i’'ve already configure my sip.conf file but i forgot to put the configuration complete in my last post, Im Sorry. I have edited the post, can you check it again please?

Thank you for helping me.

Greetings from Mexico !

Are you seeing any exceptions in the log file indicating what is going wrong?



nop, there is anything y my error log. the questions are:

What should i put in the phone Mappings form to enable the phone calls throug spark client?


are my asterisk’'s configuration files rigth to do what im trying to do?

Thank you !!!

I wasn’‘t clear that you hadn’'t filled out the phone mappings:

username : wildfire username

phone /device: SIP/100 or SIP/101

extension: 100 or 101

caller id: user1 or user2

primary: doesn’'t matter until you have more than one number for a user.

Hope that helps,


hi Again !!

I’‘ve been testing my asterisk-im configuration but it’‘s still not working, I’‘ve registered the users in the phone mapping form just like you said and it works but when I start sesion in spark a dont see any call button enabled, the only way to make calls is doing rigth click on the name of the user that im trying to call, when i try , asterisk’'s console shows me this message:

“Oct 3 09:20:05 NOTICE[3815]: channel.c:2491 __ast_request_and_dial: Unable to request channel SIP/user2”

All my users and extensions are registered just like a posted before And i dont know what is going on? can you help me?.. typing “sip show settings” in the asterisk consoles shows this:

Global Settings:

SIP Port: 5060


Videosupport: Yes

AutoCreatePeer: No

Allow unknown access: Yes

Promsic. redir: No

SIP domain support: No

Call to non-local dom.: Yes

URI user is phone no: No

Our auth realm localhost

Realm. auth: No

Always auth rejects: No

User Agent: Asterisk PBX

MWI checking interval: 10 secs

Reg. context: (not set)

Caller ID: asterisk

From: Domain:

Record SIP history: Off

Call Events: Off

IP ToS: 0x0

OSP Support: No

SIP realtime: Disabled

Global Signalling Settings:

Codecs: ulaw,alaw,speex,gsm,h261,h263,h263p

Relax DTMF: No

Compact SIP headers: No

RTP Timeout: 0 (Disabled)

RTP Hold Timeout: 0 (Disabled)

MWI NOTIFY mime type: application/simple-message-summary

DNS SRV lookup: Yes

Pedantic SIP support: No

Reg. max duration: 3600 secs

Reg. default duration: 120 secs

Outbound reg. timeout: 20 secs

Outbound reg. attempts: 0

Notify ringing state: Yes

Default Settings:

Context: default

Nat: RFC3581

DTMF: rfc2833

Qualify: 0

Use ClientCode: No

Progress inband: Never

Language: (Defaults to English)

Musicclass: default

Voice Mail Extension: asterisk

Thank you and I hope that this can be useful fore someone else too

Greetings !!

after 2 weeks, I have’'nt made Asterisk IM works in my LAN, last week when i made a call using spark i was getting this error message:

“Oct 3 09:20:05 NOTICE3815: channel.c:2491 __ast_request_and_dial: Unable to request channel SIP/user2”

Now after a lot of configurations spark connection with wildfire crash when i try to make a call and asterisk console does’'nt shows anything… now the question is… someone really has made this plugin works fine?

If someone did, could share his/her config files of asterisk ?

help please ! all the information about my configuration and version is in the previus posts of this thread.

Thank you from Mexico !