Strange problem?

i use spark to log on the wildfire.

i open the spark.exe, set “advanced” -> general -> connection:

host: my wildfire ip

port: 5222

it can connect to the wildfire correctly.

Now i wrote a proxy, it’'s set between spark and wildfire.

proxy just recv spark and send to wildfire, recv wildfire and send to spark;

so set “advanced” -> general -> connection:

host: proxy ip

port: proxy port

spark can not connect to the wildfire, why?

the trace information:

Waiting for a client to connect…

recv from spark:

recv from spark:

?b… //here is the unvisiable code

send to the WildFire…

?b… //here is the unvisiable code

over, connect failed


does the connection also fail if you disable TLS in Wildfire?



how can i disable the TLS?

i did not see the option?

hi it2000:

thanks first.

i disable the TLS in wildfire, and spark success to log on the wildfire via my proxy.

but why ? proxy do not modify the recv string, it just transmits whatever recieved.

y can’'t not log on while TLS is optional or must/



if TLS is optional Spark will use TLS. So I wonder if your proxy does change something within the TCP packet that makes the TLS negotiation fail, I don’'t have a detailed knowledge of the SSL/TLS specifications so I can just guess that this is the case.

I run Pen as a simple TCP load balancer in front of two connection managers without problems, so you could try to use it as a TCP proxy for Wildfire and see if this still fails.