powered by Jive Software

Strange warning in OF logs

I’ve updated OpenFire to the latest version 4.6.5 and noticed in logs the lines with warnings like:

2021.12.15 08:48:28 org.jivesoftware.util.SystemProperty - Configured property p@local is not a valid JID

JID is changed in above example. The real JID is longer and the JID is the JID of the real OpenFire user.
In previous version there weren’t such warnings. I’ve searched the warning logs before the updation of OpenFire.

It’s kind of hard to diagnose a “invalid value” type of error when we do not know what the value is that’s causing the error.

To my knowledge, nothing has changed in the parsing of text-as-JIDs. Do you know what property this JID is a value of?

I’ve found the property with this JID in. It is admin.authorizedJIDs (I used the MS SQL Server Management Studio to see the contents of the fields in table dbo.ofProperty). On some day maybe a year ago I’ve entered there two values separated by comma. The first value is admin@local and the second one is p@local that I mentioned in my start message. In previous version of the OpenFire (4.4.4) the was no warning on this property.
And an interesting fact that in admin console I can see only admin@local and no comma and no second JID p@local.

Have you tried setting the comma-separated values for the property again?

I’ve tried to set the same comma separated values today. But I’ve done more :slight_smile:
And now I can say:

  1. Adding one JID is fine. I can see the right data (one JID) both in the admin console of OpenFire and in the MS SQL table.
  2. Adding two JIDs separated by comma is not fine. I can see the right data (two JIDs) in the MS SQL table and only first JID in the admin console.
  3. Adding two JIDs in two rows of input field is not fine at all. I can see I hope the right data (two JIDs separated by spaces or maybe by <LF> or <CR>) in the MS SQL table and no data in the admin console. In the admin console it shows like "none" in the property table.

Weird, this seems to work just fine for me, with Openfire 4.6.5, as shown below. Do your JIDs consist of non-ASCII characters (maybe there’s an issue with character encoding)?


I see. Your screenshots tell more than words :slight_smile:
My input was: first JID, a comma, one space after the comma and second JID. When I entered two JIDs separated by comma and no space between, everything works as expected.

Pfff… let’s fix that in Openfire. I’ve raised this issue: [OF-2354] String-based SystemProperty lists should allow for whitespace comma separation - Ignite Realtime Jira