powered by Jive Software

Strophe to connection manager

I failed to connect with javascript to openfire’s connection manager (which I well installed) using Strophe library:

conn = new Strophe.Connection('http://xx.xx.xx.xx:7070/http-bind/');
conn.connect(XMPP_JID, XMPP_PASSWORD, OnConnectionStatus);

**/opt/connection_manager/conf/manager.xml: **

<!-- Configure http binding. -->
        <httpbind>
            <enabled>true</enabled>
            <port>
                <plain>7070</plain>
                <secure>7443</secure>
            </port>
            <!-- Script syntax allows BOSH to be used in environments where clients may be restricted to using a particular server -->
            <scriptSyntax>
                <enabled>true</enabled>
            </scriptSyntax>
            <client>
                <requests>
                    <!-- Longest time (in seconds) to wait before responding to any request during the session -->
                    <!-- <wait></wait> -->
                    <!-- Maximum allowable seconds over which a client can send empty requests to the server -->
                    <polling>5</polling>
                    <!-- Limit number of simultaneous requests the client makes with the 'requests' attribute -->
                    <max>2</max>
                </requests>
                <!-- Seconds a session has to be idle to be closed -->
                <idle>30</idle>
            </client>
        </httpbind>
    </xmpp>

Any other modifications to do in configure.xml or apache conf?