powered by Jive Software

Stuck on "Waiting for Authentication"

I have installed the latest Openfire on my QNAP NAS, a Mac-mini and on a Windows machine

with the minimum default configuration using the local database option and no changes to any

of the out-of-the-box settings. Two users were created and put into a single named group.

Each user can log-in to the server and can add the other user to their contacts.

No messages from user to user get through and each user sees the “Waiting for Authentication”

message with their added user (when unsecure there is no “waiting” message - and no chat messages either).

This is the case regardless of the settings of options allowing or requiring secure chat sessions.

I have router ports open and recommended DNS SRV records setup. I have examined all the

apparently relevant community posts and other postings on the web but I haven’t found a solution

so I now feel like I’m justified to ask for some help - any ideas on what I may be missing or doing wrong?

Do you login with clients on the same PC where server is installed? What clients do you use? What do you put into Domain field in the clients?

Thank you for replying so quickly !!!

The Openfire server is on its own machine.

Clients are Jitsi and Spark and they log in from other machines.

The users are created as “name” on the server and the client accounts are created with "name@domain.com"

The Openfire server uses the same domain as the public name so its “domain.com” not “domain.domain.com”.

I have all the openfire required ports open including the etheral ports 30000-50000 for jingle.

If there is a minimal installation I can configure to demonstrate functionality I would like to start with that -

then I can add and test other capabilities to get the functionality I want without bothering the community for help -

(it’s so nice to be able to get great software like this open source that I feel kinda bad asking for help).

When you say they are able to add each other, do they get a request at that point, to allow subscription from another user? Probably not. I don’t remember seeing Waiting for authorization in Spark. Maybe that’s on the Jitsi side? Can you try with two Spark clients? So in Admin Console your XMPP domain is domain.com?

They can add contacts to their contact list but the contact they added does not get a request.

In Spark it’s “name - pending” while in Jitsi it’s “Waiting for Authentication” - I think they are equivalent.

I’m trying now with only Spark clients and my server shows XMPP Domain Name: “domain”, not “domain.com”.

Thank You !

If your xmpp domain is ‘domain’, you should put ‘domain’ in the Domain field in the clients. Of course, ‘domain’ should be resolvable in the network. If you want to use ‘domain.com’ as your xmpp domain, then i suggest starting from scratch and set it like that in the setup process.

Instead of a re-install (instead of starting from scratch) I tried to change the property for the XMPP Domain Name from “domain” to “domain.com” and that seemed to work! . . . Genius I’d say . . . Thank You!

I’m going to do some more testing but so far that seemed to fix the problem with Spark and with Jitsi.

If it all works after testing I’ll mark it off as the correct answer.

Thank you again for your quick response and insight.

I figured that in the testing phase it should be easy to start over Renaming the system property is an option, but not for production, when some users might already have added users with the older domain name.