powered by Jive Software

System properties not working? Openfire 3.6.4

Hello there,

I’ve recently installed Openfire version 3.6.4 (java: java version “1.6.0_02”, Java™ SE Runtime Environment (build 1.6.0_02-b05), Java HotSpot™ Client VM (build 1.6.0_02-b05, mixed mode) ) on Gentoo (2.6.22-gentoo-r8) and everything is working fine except system properties. My server is using MySQL to r/w and it’s not an issue.

Specifically, xmpp.muc.tasks.log.timeout doesn’t seem to be taken into account, even after a openfire restart. I’ve set the value to 2500 (2,5s) rather than the default at 300000 ms.

I’ve been here already: http://www.igniterealtime.org/community/docs/DOC-1061

Thank you!

Hi,

Looking at the sourcecode of MultiUserChatServiceImpl.java , it appears the property is “tasks.log.timeout” ? Perhaps I am missing something about how the muc service looks up properties.

daryl

Ah,

I think I figured it out. You need to make that setting change on the Admin Console. Go to the Group Chat tab then select your conference service. Then go to “Other Settings”. You can set it there. The value ‘tasks.log.timeout’ is then stored in the ofMucServiceProp table.

The multi-muc-service code added in 3.6.0 changed how those properties are set.

daryl

Ah that’s terrific, thanks alot for your help, sure did the trick.

…can’t believe I missed it.