powered by Jive Software

Talk problem - gtalk user is not able to log in

hi,

I have enabled the gtalk transport in my Openfire 3.3.0 and I am using IM Gateway 1.0.1. I am able to successfully talk and login into the

MSN, yahoo IM gateways. However I am having problem with gtalk and

jabber.

First of the all the Google Transport is not visible in the Spark IM Client (2.5.1) but appears in jabbin (http://www.jabbin.com), Coccinella (http://hem.fyristorg.com/matben).

When i click on the google/gtalk transport - register, after entering

the details as “user” “password”, i get the message that the

registration has been successful, but in the error.log I get the

following errors


2007.04.25 18:02:39 org.jivesoftware.openfire.gateway.protocols.xmpp.XMPPSession.logIn(XMPPSession.j ava:80) gtalk user is not able to log in: massoo

Connection failed. No response from server.:

at org.jivesoftware.smack.PacketReader.startup(PacketReader.java:164)

at org.jivesoftware.smack.XMPPConnection.initConnection(XMPPConnection.java:875)

at org.jivesoftware.smack.XMPPConnection.connectUsingConfiguration(XMPPConnection. java:834)

at org.jivesoftware.smack.XMPPConnection.connect(XMPPConnection.java:1276)

at org.jivesoftware.openfire.gateway.protocols.xmpp.XMPPSession.logIn(XMPPSession. java:73)

at org.jivesoftware.openfire.gateway.protocols.xmpp.XMPPTransport.registrationLogg edIn(XMPPTransport.java:88)

at org.jivesoftware.openfire.gateway.BaseTransport.processPacket(BaseTransport.jav a:302)

at org.jivesoftware.openfire.gateway.BaseTransport.processPacket(BaseTransport.jav a:144)

at

org.jivesoftware.openfire.component.InternalComponentManager$RoutableComponent.p rocess(InternalComponentManager.java:490)

at org.jivesoftware.openfire.net.SocketPacketWriteHandler.process(SocketPacketWrit eHandler.java:55)

at org.jivesoftware.openfire.spi.PacketDelivererImpl.deliver(PacketDelivererImpl.j ava:48)

at org.jivesoftware.openfire.spi.PresenceManagerImpl.probePresence(PresenceManager Impl.java:381)

at org.jivesoftware.openfire.spi.PresenceManagerImpl.handleProbe(PresenceManagerIm pl.java:279)

at org.jivesoftware.openfire.PresenceRouter.handle(PresenceRouter.java:162)

at org.jivesoftware.openfire.PresenceRouter.route(PresenceRouter.java:69)

at org.jivesoftware.openfire.spi.PacketRouterImpl.route(PacketRouterImpl.java:75)

at org.jivesoftware.openfire.spi.PacketRouterImpl.route(PacketRouterImpl.java:56)

at org.jivesoftware.openfire.component.InternalComponentManager.sendPacket(Interna lComponentManager.java:186)

at org.jivesoftware.openfire.gateway.BaseTransport.sendPacket(BaseTransport.java:1 495)

at org.jivesoftware.openfire.gateway.BaseTransport.addNewRegistration(BaseTranspor t.java:1336)

at org.jivesoftware.openfire.gateway.BaseTransport.handleIQRegister(BaseTransport. java:674)

at org.jivesoftware.openfire.gateway.BaseTransport.processPacket(BaseTransport.jav a:435)

at org.jivesoftware.openfire.gateway.BaseTransport.processPacket(BaseTransport.jav a:141)

at

org.jivesoftware.openfire.component.InternalComponentManager$RoutableComponent.p rocess(InternalComponentManager.java:490)

at org.jivesoftware.openfire.IQRouter.handle(IQRouter.java:250)

at org.jivesoftware.openfire.IQRouter.route(IQRouter.java:104)

at org.jivesoftware.openfire.spi.PacketRouterImpl.route(PacketRouterImpl.java:67)

at org.jivesoftware.openfire.net.StanzaHandler.processIQ(StanzaHandler.java:289)

at org.jivesoftware.openfire.net.ClientStanzaHandler.processIQ(ClientStanzaHandler .java:79)

at org.jivesoftware.openfire.net.StanzaHandler.process(StanzaHandler.java:254)

at org.jivesoftware.openfire.net.StanzaHandler.process(StanzaHandler.java:153)

at org.jivesoftware.openfire.nio.ConnectionHandler.messageReceived(ConnectionHandl er.java:132)

at org.apache.mina.common.support.AbstractIoFilterChain$TailFilter.messageReceived (AbstractIoFilterChain.java:703)

at org.apache.mina.common.support.AbstractIoFilterChain.callNextMessageReceived(Ab stractIoFilterChain.java:362)

at org.apache.mina.common.support.AbstractIoFilterChain.access$1100(AbstractIoFilt erChain.java:54)

at org.apache.mina.common.support.AbstractIoFilterChain$EntryImpl$1.messageReceive d(AbstractIoFilterChain.java:800)

at org.apache.mina.filter.codec.support.SimpleProtocolDecoderOutput.flush(SimplePr otocolDecoderOutput.java:62)

at org.apache.mina.filter.codec.ProtocolCodecFilter.messageReceived(ProtocolCodecF ilter.java:200)

at org.apache.mina.common.support.AbstractIoFilterChain.callNextMessageReceived(Ab stractIoFilterChain.java:362)

at org.apache.mina.common.support.AbstractIoFilterChain.access$1100(AbstractIoFilt erChain.java:54)

at org.apache.mina.common.support.AbstractIoFilterChain$EntryImpl$1.messageReceive d(AbstractIoFilterChain.java:800)

at org.apache.mina.filter.executor.ExecutorFilter.processEvent(ExecutorFilter.java :266)

at org.apache.mina.filter.executor.ExecutorFilter$ProcessEventsRunnable.run(Execut orFilter.java:326)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)


But, I am able to login independently into gtalk from both jabbin / cocinella as the above tried user.

The details for the openfire im server are :

Servername : email.mobiapps.com

mysql db : openfire

user : user

password : password

admin login url : http://127.0.0.1:4040 or https://127.0.0.1:4041

admin login credentials :

admin / domain pass

Ldap Settings :

Host : 172.16.1.2

Port : 389

BaseDN : ou=Users,dc=mobiapps,dc=com

AdministratorDN : cn=Manager,dc=mobiapps,dc=com

Server-Server Port : 4042

Component Port : 4043

Client Port : 4044

Client SSL Port : 4045

HTTP Binding Port : 4046

HTTP Binding SSL Port : 4047

All addresses : 10000 - 20000 : Real time media proxy

All addresses : 3478 & 3479 : STUN Service

I have opened all the required ports except those for Media Proxy &

STUN Service and I am able to telnet to port 5222 of both jabber and

talk.google.com and the tests show the status as successful from the

web-admin console.

Please help me how to resolve this.

Regards

Prashant

?? -Why- are you using the IM Gateway plugin out of SVN? That is not version 1.0.1 as it’'s released on the actual plugin release page. GTalk/XMPP support is not even remotely finished yet and is very broken and causes problems for the other transports as well. =) Is there a build sitting around somewhere that has these in it or did you indeed pull it from SVN?

I have the same version; I downloaded it the usual way and have both XMPP and GTalk as experimental gateways.

How big should the official plug-in jar be?

I don’‘t know but holy crap! I’‘ll get up with the Jive people to ask what’‘s going on!!! Thanks y’'all!

Actually the real one should be 677549 (-not- 1746854 like the one i just downloaded)

I’'ve been running the larger version for over a week.

Openfire has become unstable (it seems to lock up every night) and I’'ve been getting frequent disconnections from MSN.

Seems we may have found it why! I look forward to getting the production ready version back - it was rock solid on Wildfire

My build has gtalk and xmpp as well. I tried using gtalk and it did not work. It was odd because although gtalk was a choice, it had no icon. I pulled the copy of the plugin I am using off the plugins page (not beta).

-Andy

Until I can get it fixed on the real page, see attached!!!

This is just bizarre… I’'ve see a couple of other weirdities occur with my plugin before … like at one point beta 7 mysteriously reappeared on the beta plugins page. Going to try to get to the bottom of that today. =/
gateway.jar (677549 Bytes)

Also see: http://www.igniterealtime.org/forum/thread.jspa?threadID=26194&tstart=0 =)