TCP Port Question

OK, this is an odd question, but I’‘m not sure if there’'s something wrong with Wildfire or not.

The last few days Wildfire has been hanging, and creating LOTS of threads (it dies around 5,000).

The problem is I only have about 300 sessions in progress. Looking through a netstat dump, there’'s lots of entries like this (IP changed):

Wildfire listens on port 80, so people aren’'t confused.



It looks like there’‘s a “loopback” being created… there are thousands of these, and I know that Wildfire is creating the sockets because I ran a tool that shows what process owns a particular socket, and it’'s java.exe

Why are so many of these being created, and does anyone have ideas for why I’'m getting so many threads now?

I’‘m running a MySQL 5.0 database for Wildfire, and that is running fine also. At first, I thought there was something there, but it seems to be fine. I’'m also running with:

c:\jdk1.6.0\bin\java -Xss128k -Xoss128k -Xmx768M

I’'ve used the Wildfire JVM too, and same issue.

Message was edited by: ckuske

Hey Chris,

Which plugins are you running? Which Wildfire version are you running? Are you using the HTTP binding feature?


– Gato

Hi Gato,

I’‘m not, but I figured out the problem. There’'s one thing I forgot was on this server before I tried to start blaming you guys.

I was running a program called RINETD that redirects TCP ports (port 5222 to 80 in my case)… it was causing the socket problems… I was running out of them actually, and it was messing everything up! I didn’‘t know Win2k3 had port redirection built into the Windows firewall, so I’‘m using that instead and it’'s all cleared up.

Just wanted to post this for my future embarrassment and maybe some help to others down the line.

P.S. I really like the little things you guys added to 3.1 vs 3.0.