powered by Jive Software

The JVM could not be started. The maximum heap size (-Xmx) might be too large

I created openfired.vmoptions and openfire-service.vmoptions in the C:\Program Files\Openfire\bin and then i entered these commands:

-Xms512m -Xmx1024m

after i entered the above commands and then save it. I started the openfire application and an error prompts “The JVM could not be started.The maximum heap size (-Xmx) might too large or an antivirus or firewall too could block the execution.”

I already turned off the firewall and have no antivirus installed. I have attached a screenshot for reference. Thanks

i am using openfire server 3.9.1 version.

Hi Jay, I think you’ve using 32bit windows, and can’t use more than 3.2GB of RAM. I use 2008 x64 with 6GB and I successfuly set is to 1536m (I can’t set more, i think it it something to do with 32bit java, but Im not sure)