powered by Jive Software

The user profile picture cannot be modified

Sorry, I can’t speak English, I come from China, the following is the use of machine translation.
I’m using version 2.9.4 of Spark for Windows. The first time I set the profile picture for the user it was fine, but then I decided that the profile picture I just set was not nice and I wanted to change it, so I reset the profile picture and then something went wrong. Spark got stuck. Server does not support VCards, unable to save your VCard.
image
Logging out and trying to log in again will not work, as shown in the screenshot below:
image
I thought it was a problem with Openfire server. I have tried Openfire 4.4.0, 4.6.2 and 4.6.3, all of which had this problem. I did not try other versions.I use Openfire as a Linux version, installed in Ubuntu 18.04.

Later, I tried to install the Winodws version of Openfire (the latest version) and it’s OK, no bug. why? A Windows version and a Linux version of openfire, version number is the same, why does Linux have a bug, but Windows does not have a bug, I searched Google “Server does not support VCards”, can not find the answer, Why does Server not support vCards? the Settings for Windows and Linux are exactly the same. I did not use LDAP, the Settings are as follows:

What version of Java you have in Openfire in both cases? It is shown on the first page of Admin Console.

It’s 1.8.0_291 in Windows,1.8.0_261 in Ubuntu,screenshot as follows:
Image 1 Image 2

The Windows environment is OK, and I have installed the Java version of Ubuntu to be the same as Windows, but the problems remain.

Do you have similar setup though? I mean i see some domain name in Ubuntu and IP address in Windows variant. This might be the difference causing the error. Try setting up Openfire on Windows with some domain name and logging it in Spark using that name instead of IP. Also, on Ubuntu do you use domain name to login in Spark? And do you run Spark on the same machine as a server in both cases or from a remote machine?