powered by Jive Software

There are no active connection managers in Openfire

My net is a Forest with the domain X.COM and the same father’s childdomain: Y.X.COM, Z.X.COM, etc. I have installed an Openfire 3.8.2 in the domain X.COM with Windows 2003 Enterprise Editions SP2 and I have configured a Connection Manager 3.6.3 correctly in each one of the childdomain: Y.X.COM AND Z.X.COM with Windows 2003 Enterprise Editions SP2 and I don’t see any active connection in Openfire.

The configurations recommended in internet in the connection managers are the following ones:

<!-- Name of the server to connect. This property is required. -->
<domain> Name of the server.X.COM</domain>
<!-- Password to use to log into the server. This property is required. -->
<password>XXX</password>
<!-- Flag that indicates if certificates of the server should be validated. -->
<verify>false</verify>

I search for internet and anything has been solved the problem and I have my boss a little impatient.

Please some help!

I don’t understand the Forest vs Father’s/Child childdomain. I assume that you’re referring to an ActiveDirectory setup, which is completely unrelated to the usage of Connection Managers.

Please note that, although useful in concept, the connection manager is quite old, and has not gotten important updates. Clients that connect through the connection manager might suffer from issues that do not occur while connecting to Openfire directly. An alternative to using connection managers would be to use Openfire in a clustered environment.

That being said: it appears that you are missing a line in your configuration. As ‘domain’, you should fill out your XMPP domain (which I think in your example is X.COM. This should match with the XMPP domain name as you have configured it in Openfire (which is often referred to as a ‘server name’, which is an artifact from the time where Openfire could not be clustered. Do not confuse this with ‘host name’!)

After setting your domain, you can define to which server/host/ip your connection manager can connect to, by using a ‘hostname’ element. This should point to the DNS name (or IP address) of the server.

<!-- Name of the server to connect. This property is required. -->
<domain>X.org</domain>
<!-- IP address or hostname of the XMPP server. If not defined then a DNS SRV lookup of the domain will be performed. -->
<hostname>Name of the server.X.org</hostname>
<!-- Password to use to log into the server. This property is required. -->  <password>XXX</password>  <!-- Flag that indicates if certificates of the server should be validated. -->  <verify>false</verify>

Thank you to respond so soon.

I will change my work strategy. I going to install Openfire 4.0.2 in each domain and the communication between the users of each domain S2S is solved.

Hi,

i have got the same problem:

Openfireserver: Windows Server 2012 R2

Connectionmanagerserver: Windows Server 2012 R2

  • Ports are open (try it with telnet)

  • I had to set the java_home variable because my server dont get it

  • i edit the manager.xml :

Domain: TRY.com

hostname: OFSERVER01.TRY.com

password: 123456

Flak certificates: false

  • i edited on my openfireserver the connection manager to true

  • i started the batch, but NOTHING happens, only the CMD pops out

  • if i try to debug this (edited the manager.xml to true) nothings happend

i dont know what i have to do.