powered by Jive Software

TLS v1.2

I know that Openfire supports TLS, but not the version. I need to know if Openfire supports TLS v1.2. Thank you.

Well, feel free to provide a patch to OF to allow this. I am sure that Guus will review and include, if it is ok.

Walter, i think he is not asking for supporting this version, but asks what version Openfire currently supports. have no clue have to check this.

Yes, this was my question.

I would also be interested which version of TLS Openfire supports: TLS1.0, TLS1.1, TLS1.2, or even TLS1.3? And how can I find this out?

Afaik it depends on the java version you run openfire with.

Java 7 supports TLS1.2 and Java 8 uses it as default. If you use Java 6 TLS 1.2 is not supported.

You could check the supported TLS version of your openfire installation at the xmpp.net.