powered by Jive Software

Trouble installing new 3.8

Hi there community,

Congrats for this new release. I’ve been running Openfire for years now and I’m glad to see the project growing.

I’ve installed a lab machine, Debian 6 with Sun Java JRE runtime (tried openjdk as well) with openfire 3.8 (tar.gz package). My auth configuration is baed on ldap so I started the configuration with that in mind. But I’m unable to finish the setup wizard. When I begin configuring ldap I’m unable to get past even step 1. Once all the fields have been filled I click on “test settings” and nothing happens. Not a popup (I’ve enabled them), nothing at all. Any hints?

Regards!

I noticed this as well. However, I continued through without testing and everything works.

Hi,

Does anything get logged to the openfire logs folder?

daryl

The only thing I see in the logs is:

2013.02.07 12:34:37 org.jivesoftware.openfire.handler.IQvCardHandler - VCard provider is read-only.

java.lang.UnsupportedOperationException: VCard provider is read-only.

at org.jivesoftware.openfire.vcard.VCardManager.setVCard(VCardManager.java:158)

at org.jivesoftware.openfire.handler.IQvCardHandler.handleIQ(IQvCardHandler.java:9 5)

at org.jivesoftware.openfire.handler.IQHandler.process(IQHandler.java:65)

at org.jivesoftware.openfire.IQRouter.handle(IQRouter.java:372)

at org.jivesoftware.openfire.IQRouter.route(IQRouter.java:121)

at org.jivesoftware.openfire.spi.PacketRouterImpl.route(PacketRouterImpl.java:76)

at org.jivesoftware.openfire.net.StanzaHandler.processIQ(StanzaHandler.java:337)

at org.jivesoftware.openfire.net.ClientStanzaHandler.processIQ(ClientStanzaHandler .java:93)

at org.jivesoftware.openfire.net.StanzaHandler.process(StanzaHandler.java:302)

at org.jivesoftware.openfire.net.StanzaHandler.process(StanzaHandler.java:194)

at org.jivesoftware.openfire.nio.ConnectionHandler.messageReceived(ConnectionHandl er.java:181)

-Justin

Hi,

I have the same problem, i can’t completed the installation because the test button don’t work.

I have a glpi server on the same W2008r2 server and my ad config works fine.

I tried to continue whitout testing but it hang over on the admin profile because no user was found.

Thanks for your help…

PS: Excuse my poor english, i’m french…

As Justin said, if you complete the whole ldap wizard you’ll end up finishing the setup and , in fact, it’ll work alright. Make sure you use the correct ldap settings , otherwise you may find yourself unable to log in afterwards (it’ll need some tweaking though).

Nairod, pas de problème, moi, je suis espagnol xD I used Google Chrome to complete the setup (used IE and Ff as well, same results). But with Chrome you can easily turn on the embedded java console. If you click on the erratic java files you’ll get a tab with the results (same as if you pressed the Test button) … seems to be something related with popups

Thx a lot, it works…