powered by Jive Software

Trouble installing Red5

I’m fairly new to Openfire and XMPP in general. I have installed the OpenFire server on my Win2k3 domain and it runs without issue. My family has been using a mixture of Psi and Spark to chat almost daily.

I decided I’d like to add video (webcam) capability, and it seems Red5 is the best, if not the only, way to go about this. However, I can’t install it. I’ve followed the instructions, which say to install to the HOME/plugins directory. I’ve copied the red5.war file to the appropriate directory, but the homepage for my Openfire configuration page has not changed. Also, there are no new items under the Plugins tab. It’s as if the Openfire server does not even see the .war file.

Maybe I’m missing something here, but I thought Red5 was a free upgrade. Do I need to be running the “Enterprise” version of OpenFire to install a plugin which is freely available?? If so, this is not feasible for my small family. I would rather remove Openfire from my system, and install an opensource/free server.

Please advise…

Also, if I go to http://server:9090/reg5, or http://server:9090/reg5/red5.html, I get the following message:

HTTP ERROR: 404

NOT_FOUND

RequestURI=/reg5

Powered by Jetty://

If I try to browse for the file and open it from Windows Explorer, I get a message that JID is not installed. I searched around, but have no idea what JID is…

do you have the red5 server installed on the same same computer as the openfire

download at http://osflash.org/red5

also you will need jave 1.6 3D for the server

you will need openfire 3.3.3 and red5 V 0.0.9 is the most stable

JID is jabber ID example username@yourserver.com

Thanks! I will work on it over the weekend!

I’ll post back here with the results.

Hello Bruce!

I had installed openfire 3.3.3 and red5 V 0.0.9 and java 1.6. But I still get problem to access http://server:9090/reg5 (error 404). I tried in Debian Etch.

What can I do now?

I dont have the red5 server. Do I must install ? What version? Because red5 v0.6.3 server needs java 1.5!!!

Ahh…if I try http://server:9090/plugins/red5 appears

Red5 Properties.

and 1.6 with 3D works better check the JWChat and chatrooms post and you can test drive mine.And yes you need the red5 server installed to you C drive of the same computer as the openfire or plugin will not work .Other things to chack fire wall for ports you could allso try http://yourIP:9090/red5/

Does it shoe you your admin panel in server tab as red5 gateway and in plugins tab as installed

here is java 1.6

I installed the red5 server and java1.6 but I still get the messages:


8<----


HTTP ERROR: 404NOT_FOUND

RequestURI=/red5/

Powered by Jetty://


8<----


How can I check the JWChat ?

My firewall is OK…ACCEPT everything. I can access the http://myIP:9090…but not http://myIP:9090/red5

Do you have some HowTo to install the red5 server and red5-plugin ? I guess my red5 server is OK, because I can access: http://myIP:5080. Am I correct?

Thanks in advance.

Finnally I did the red5 server and plugin works.

I installed the java 1.6, installed red5 server ( http://osflash.org/red5/debian?s=debian) and the openfire 3.3.3 with the red5 plugin.

Now the red5 plugin work, but the video image is to small. Can I increase the video image?

Hi,

can you provide red5 server install help (Bruce00)?

During my install i followed these instructions: http://osflash.org/red5/linux-install

It all went well until i followed the next few steps*:*

www:~/red5 # ant prepare

Buildfile: build.xml

  • java.home is /usr/java/jdk1.6.0_03/jre and the target version is 1.6*<<br />***BUILD SUCCESSFUL**+
    

The next step gives me an error:

www:~/red5 # ant build

Buildfile: build.xml

  • java.home is /usr/java/jdk1.6.0_03/jre and the target version is 1.6+
    

BUILD FAILED

Target “build” does not exist in the project “RED5”.

In this case the last step does not work:

www:~/red5 # cd dist

www:~/red5/dist # sh red5.sh

red5.sh: red5.sh: No such file or directory

Maybe you got a clou of what i am doing wrong?

Thanks in advance.

Message was edited by: rene-1 - Printing the right error message.

I am having the same issue…

I cannot connect to the red5 via:

http://EXAMPLE.com:9090/red5/index.html

But:

http://EXAMPLE.com:5080/demos/ofla_demo.swf

Works like a charm…Get Video streams and everything test just fine…

Any help would be appreciated…

Yes I have Red5 Installed on the Same server as Openfire…

Yes I currently have every port in the world open to the server…But will have to close them down as it get’s going…

Thanks

Bret@TopDogAviation.com