powered by Jive Software

Trouble running Redfire with Openfire 3.7.1

I wonder if anyone can help me with this.

One a machine with: Windows 7 Enterprise (64-bit)

I have installed:Openfire 3.7.1

The server and Spark client seem to work fine at this point.

Then I stopped the Openfire server, copied the redfire.war file to the Openfire home directory.

The version I was using was the latest version in redfire-370-0.0.06.zip.

When starting up Openfire, a long list of error messages appeared.

First section indicated multiple sfl4j bindings.

Then a bunch of logback errors.

Then RedSSIP started, with a list of alloc ports.

Then Red5Phone started.

Then Red5XMPP started.

Then java.sql.SQLException: Table not found in statement [INSERT INTO ofvoicebridge …]

And then a bunch of other messages.

It’s hard for me to discren where the problem is, or whether there is a problem. The complete error log is attached in a txt file if anyone wants to look at it.

Your help will be much appreciated.
red5err.txt.zip (3435 Bytes)

I think I have Redfire running. At least Openfire hasn’t crashed, and I’ve been able to use the admin console. Now the Redfire plugin for Spark isn’t working. It’s the same issue as this:

Are the two issues related? Would the error messages above cause the video to not appear? Or would I need to add a web server to the openfire server machine? (I’m using a Windows 7 Enterpise machine for the server, but I don’t have a web server running on that machine.)

Answering this question might help the other poster too.

Got it woking spledidly.Simply changed its server name to its IP address.

In the admin console I clicked server properties, then scrolled down to serve name and clicked on the “edit” icon. There I changed the server name to its IP address.

After restarting the server and both Spark clients, the Redfire video chat worked flawlessly.

Hey,

i am getting the same huge list of warning/errors as i mentioned here in the blogpost. What did you change? My propertiese are looking fine. Where do i find “spledidly.Simply”?

Thanks!

What I found was that all the warnings amounted to nothing. It still worked. Where I was having trouble was logging into the Openfire admin console. What solved that problem was resetting the Openfire server to match the computer’s IP address. To do this, I:

  1. Ran CMD and entered “ipconfig” at the command prompt.

  2. Recorded the computer’s IP address.

  3. Logged into the Admin Console.

  4. Clicked on Server Properties.

  5. Scrolled down the properties list until I saw “Server Name.”

  6. Edited the property, replacing it with the IP address I recorded earlier.

  7. Saved the new setting and restarted Openfire.

I had no problems entering the Admin Console after that. The error messages remained. My experience with Openfire is that most of these errors come after a plugin is installed, and most them turned out to be information-type messages instead of the warning type.

Awh i don’t have this property “Server Name”? :slight_smile:

I only have “xmpp.domain” and that points to my hostname jabber-server.de

On the mainpage of my admin console it says Servername: jabber-server.de with a warning: Found RSA certificate that is not valid for the server domain <- this is the self signed certificate i was talking about.

This certtificate signed to the servers ip adress and not the hostname. But if i change the servame to its ip adress im getting into trouble with some services like conference because now they are only accessable via ip and not domain. So i would rather stick to my hostname as servername.