powered by Jive Software

Trouble with translator plugin

I’m using spark 2.5.8 against openfire 3.6.4.

I would like to use the translator plugin (1.2) to communicate between users that speak different languages.

I added the plugin and that part worked fine.

When I select a translation option other than ‘no translation’, the recipient never receives the message sent by the sender – neither in english nor in the translated language.

Without any translation, things work as expected.

I’ve also tried spark 2.6.0, but there was no change in the behavior.

I tried the client with the debugger running, but that didn’t point to any errors.

I wasn’t able to find any documentation that pointed to server-side configuration I was missing.

Any help would be appreciated.

Thanks,

doug

Here is a little more information on the issue:

With debug enabled on spark, here is what a normal chat message saying ‘hello’ shows:

hello

rNOfPF

<offline/>

<composing/>

And here is what shows when the translator is invoked…

rNOfPF

<offline/>

<composing/>

Note the missing section. This would explain the symptom in the first posting.

A packet capture during the chat session shows spark (with translation enabled) reaching out to the google translate service, and the service responding with the correct translation.

It appears, however, that the response doesn’t get parsed correctly or there is some hiccup in applying the translation to the section of the chat.

Perhaps a google service upgrade broke some functionality?

Perhaps something else.

If anyone has other experience or a workaround, I’d be interested in knowing.

Thanks,

doug

I have filed this issue as SPARK-1255 but can’t say who and when will look into this. Can’t even install this plugin with the latest Spark build.

Thank you.

I also had an issue installing the translator plugin on Spark 2.6.0_11392.

doug

fixed the bug. translator plugin now works with my Spark 2.6.0 RC1. Dont know if the RC2 will have this plugin by default. if you want to use the translator plugin use my one and dont download it from the ignite server until it is updated.

(i will try to fix the plugin download problem in spark tomorrow)
translator.jar (502099 Bytes)

Wow, fantastic!

Many thanks for your contributions to this project – both past and current.

I have your plugin running in both 2.5.8 and 2.6.0_11392.

The methodology that worked best for me for a manual install…

uninstall translator plugin version 1.2

stop spark

copy translator.jar (download link above) into the …\spark\plugins directory

start spark

the new plugin appears as version 1.4

Again, thank you for your prompt fix on the plugin. I am looking forward to using it.

doug

not working with latest spark version?