powered by Jive Software

Trying to install Fastpath Webchat

Hi,

After updating to 3.7.0 (from 3.6.4) installing webchat plugin doesn’t work

I tried to install it from “available plugins”: it downloads fine (the “install” link disappears and the war file appears in the plugins directory), but it doesn’t install - the plugin remains in the “available plugins” list, and doesn’t appear in the (installed) “plugins” list. Restarting the server didn’t fix this.

Every other plugin installs fine…

Any ideas?

thanks in advance,

  • Woody

AFAIK Fastpath is broken in this version of Openfire and no one yet has fixed it.

thanks… good (and bad) to know its not just me having trouble.

Do we know if someone is working on this? FreeBSD just moved to 3.7.0.b in their port tree. But we use FP Webchat on many of our sites. Any kind of ETA or expectation it’s coming in the near future?

No, it is in need of volunteers. Anyone?

I grabbed the latest snapshot, compiled it and installed. It’s showing in the admin console as it should now. Everything appears good. No errors or warnings. But the Fastpath tab doesn’t show up in Spark. So appears it is something deeper.

In addition, WebChat doesn’t install at all. Acts as if it does, but doesn’t show in the console. I couldn’t get it to compile either.

Let’s start a new thread? Anything in the log files? Note that you can enable debugging to see if some protocol message was not sent that should be. My guess is that Spark is not seeing the Fastpath extension message.

What is the compile error associated with WebChat?

Sorry I’m delayed. Been busy. It all pertains to the original problem in the thread, but a new thread is fine. Your call.

I’m not getting any messages at all. No errors, warnings, info, or otherwise with debugging on or off. Other than the audit message saying it’s installed or removed. Which is definately not right. Not sure what’s going on. But hard to know what’s happening.

Anymore news on this?

The latest released version fixed this. Fastpath was recompiled for 3.7.0, evidently. I no longer have the problem. Thanks.

Hi there Jfrazier are you sure it already works?

I had just installed openfire Server on my computer with fastpath server and i still cant install Fastpath Webchat plugin.

any how to to get this working?

thanks

Hi. I’m new to OpenFire and FastPath.

I have installed openfire 3.7.1, and the problem with fastpath is exactly the same as described by Woody.

I have installed webchat from “available plugins”: it downloads fine (the “install” link disappears and the war file appears in the plugins directory), but it doesn’t install - the plugin remains in the “available plugins” list, and doesn’t appear in the (installed) “plugins” list. Restarting the server didn’t fix this.

Anyone with the same problem?

Maybe I should try to install 3.7.0…

Thanks!

webchat plugin war is 4.0.

No help needed…

I stumble with this thread:

http://community.igniterealtime.org/thread/46065

Make a new installation, and used this webchat.war: http://community.igniterealtime.org/servlet/JiveServlet/download/210794-10686/we bchat.war

Uploaded and now everything works fine!

Sorry for the noise…

1 Like

Still not working with 3.9.3… I installed this today and it is not working… fastpath Webchat duped me down… Someone please help

1 Like