powered by Jive Software

Trying to install on 2008 R2 64 Bit

I ran the openfire-service install from the command line and it worked, then tried to start the service, but right off the bat I’m getting an error “Windows could not start the Openfire service on local computer. Error 1:Incorrect Function” Am I missing something glaring at the moment?

Can you post some more details from Windows events.

The openfire service terminated with the following error: incorrect function

Which I realize gives basically the same error when trying to start it, but theres nothing else it gives.

I also tried this on a 32bit 2008 server and no luck, same errors.

So you are saying there is nothing for Service Control Manager in System events? nothing in Applications?

Sorry, my previous post was in the event for Service control manager. The first post is what came up when trying to manually start the service. The context is very similiar.

Having the same problem running Windows 2008 R2 64-Bit. Has anyone been able to identify a fix?

Haven’t been able to get this going as a service yet Todd…no one seems to have an answer.

Friends,

I noticed this problem at the time that the file openfire.service.vmoptions put in the variable “-Xmx” a value greater que1540m. So I could climb the service only with the "-Xmx1540m.

However need to allocate more memory to Java, someone suggests something.

Thanks.

Carlos Arêdes

Here it is Feb 1 2012 and the same error is still occuring.

Did someone fix this?

I did not find an official fix although I installed the latest spark version 3.7.1 with the latest java version, got everything up to date as far as patches and it’s working at the moment.

Getting the same error when moving to over 1550 in the -Xmx command.

Should one use g instead of ‘m’ over 1.5gb?

Just encountered this problem on a windows 2012 server with Java 8 and 64bit. Solution is to make sure you are using the 64bit version of openfire-service and replace the jre folder in openfire_home folder with jre8 from c:\program files\java (renamed to jre).