powered by Jive Software

Trying to install openfire as a service- error could not open SCManager

Anyone have any ideas about how to resolve an error with SCManager ? We are using Openfire 3.6.3 and are using the “openfire-service /install” command in the d:\program files\openfire\bin directory to try to set up openfire as a service on a domain controller running Windows Server2008. If we start Openfire by using the start menu icon our Spark clients work until we log off the server at which point the Spark clients lose connectivity with the server, so obviously we want Openfire to run in the background as a service but when we try to install it it says “could not install SCManager”. Any help would be appreciated.

1 Like

Welcome to the world of server 2008 security. I created a registry key for the service. It is attached to this doc: openfire service

After importing the key you need to change the path of the openfire install to the install location on your server. You will then need to restart the server to get the service to show in the services MMC.

1 Like

Thanks Todd !!! This is just what I needed ! Not to seem like a complete newb ( I am very new to IT work ) but can you give me a little more direction on what you mean when you say " verify the application path matches the install path for openfire on your Server 2008 by using regedit " . Thanks again !

You need to find the location in your registry for the services, edit the service the reg file created. There will be a path listed for the application the service is to run. It is currently C:\program files\openfire\bin\openfire-service.exe. See the image for the path and key in Server 2003:

ScreenShot007.jpg

1 Like

I imported the reg file, now when I use the openfire-service /start command in the D:\program files\openfire\bin folder I get an " error code 5 " message. I have not yet figured out ,by using regedit, where to verify that the application path matches the install path. Once again, any input will be appreciated !

Please refer to the picture. You need to find the service you just imported in your registry. The bottom of the window shows you the path. Edit the highlighted subkey to put in the proper path for your install.

Got it !! Everything is working great ! Now I just have to tweak 400 rosters, lol Thanks alot Todd.

Great !!

Worked very well for me too.

Thanks Guys for the post.

I know this is old, but apparently people still run into this, so I just want to point out that you simply need to open a command prompt as administrator then run the service install.

1 Like