powered by Jive Software

Ubuntu 16.04 Server update crashed web access of openfire 4.5.0

After last update of ubuntu server 16.04 there is no more webaccess to openfire.
Spark logs in, but I can’t see logged in users.

With ios or android app astrachat I can log in and see the users and can write messages.

So what happend?
Update to openfire 4.5.1 worked, but it didn’t solve the problem!
Any help?
Error log is:
less -Si /usr/share/openfire/logs/all.log
2020.02.19 22:17:10 WARN [Jetty-QTP-AdminConsole-34-acceptor-0@785edacb-ServerConnector@6835dd00{SSL,[ssl, http/1.1]}{0.0.0.0:9091}]: org.eclipse.jetty.server.AbstractConnecto
java.lang.NoClassDefFoundError: Could not initialize class sun.nio.ch.SocketChannelImpl$DefaultOptionsHolder
at sun.nio.ch.SocketChannelImpl.supportedOptions(SocketChannelImpl.java:248) ~[?:1.8.0_242]
at sun.nio.ch.SocketChannelImpl.setOption(SocketChannelImpl.java:166) ~[?:1.8.0_242]
at sun.nio.ch.SocketAdaptor.setBooleanOption(SocketAdaptor.java:284) ~[?:1.8.0_242]
at sun.nio.ch.SocketAdaptor.setTcpNoDelay(SocketAdaptor.java:319) ~[?:1.8.0_242]
at org.eclipse.jetty.server.ServerConnector.configure(ServerConnector.java:402) ~[jetty-server-9.4.18.v20190429.jar:9.4.18.v20190429]
at org.eclipse.jetty.server.ServerConnector.accepted(ServerConnector.java:394) ~[jetty-server-9.4.18.v20190429.jar:9.4.18.v20190429]
at org.eclipse.jetty.server.ServerConnector.accept(ServerConnector.java:386) ~[jetty-server-9.4.18.v20190429.jar:9.4.18.v20190429]
at org.eclipse.jetty.server.AbstractConnector$Acceptor.run(AbstractConnector.java:648) [jetty-server-9.4.18.v20190429.jar:9.4.18.v20190429]
at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:698) [jetty-util-9.4.18.v20190429.jar:9.4.18.v20190429]
at org.eclipse.jetty.util.thread.QueuedThreadPool$Runner.run(QueuedThreadPool.java:804) [jetty-util-9.4.18.v20190429.jar:9.4.18.v20190429]
at java.lang.Thread.run(Thread.java:748) [?:1.8.0_242]

Any Help?

Which version of JDK are you using? I’d guess that switch to Java 8 would resolve the problem.

Greg

i think he used java 8…

1.8.0_242 its last java 8 version

OS release upgrade to ubuntu 18.04 solved the problem but crashed php installation.
So I have to setup the server from scratch

I did complete server install from scratch on ubuntu 18.04.
Installed openfire new with mysql database.
logged in an installed the plugins.
I installed the meeting plug in and after that I coud’t log in anymore.
Problem seems it is jitsi:
2020.03.23 22:17:45 ERROR [org.jitsi.util.concurrent.RecurringRunnableExecutor.thread-org.jitsi.videobridge.health.Health]: org.jitsi.util.concurrent.RecurringRunnableEx
java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.videobridge.IceUdpTransportManager
at org.jitsi.videobridge.health.Health.doCheck(Health.java:220) ~[jitsi-videobridge-1.1-20190125.162313-103.jar!/:?]
at org.jitsi.videobridge.health.Health.doRun(Health.java:495) ~[jitsi-videobridge-1.1-20190125.162313-103.jar!/:?]
at org.jitsi.util.concurrent.PeriodicRunnableWithObject.run(PeriodicRunnableWithObject.java:87) ~[libjitsi-1.0-20190128.210332-374.jar!/:?]
at org.jitsi.util.concurrent.RecurringRunnableExecutor.run(RecurringRunnableExecutor.java:216) [libjitsi-1.0-20190128.210332-374.jar!/:?]
at org.jitsi.util.concurrent.RecurringRunnableExecutor.runInThread(RecurringRunnableExecutor.java:292) [libjitsi-1.0-20190128.210332-374.jar!/:?]
at org.jitsi.util.concurrent.RecurringRunnableExecutor.access$000(RecurringRunnableExecutor.java:36) [libjitsi-1.0-20190128.210332-374.jar!/:?]
at org.jitsi.util.concurrent.RecurringRunnableExecutor$1.run(RecurringRunnableExecutor.java:328) [libjitsi-1.0-20190128.210332-374.jar!/:?]

How can I switch of the meeting plugin without the webpage?