powered by Jive Software

Ubuntu 16. Openfire 4_3_2 Setup Stuck at setup-datasource-standard.jsp and get "ERROR StatusLogger No Log4j 2 configuration file found"

ERROR StatusLogger No Log4j 2 configuration file found. Using default configuration (logging only errors to the console), or user programmatically provided configurations. Set system property ‘log4j2.debug’ to show Log4j 2 internal initialization logging. See https://logging.apache.org/log4j/2.x/manual/configuration.html for instructions on how to configure Log4j 2

ubuntu 16, Mysql, OpenJDK8
Pliss help

What version of Openfire and how do you install? Also what version of Ubuntu (server?) exactly?

openfire 4.3.2 on ubuntu 16.04

I have recently tested installing 4.3.2 on Ubuntu Server 16.04.6. It was a clean install of both Ubuntu and Openfire. sudo dpkg -i openfire_4.3.2_all.deb worked fine without errors and i was able to run Openfire. Is it an upgrade? How do you install/run Openfire?

Before installing Openfire i have also installed Java 8.
sudo apt update
sudo apt install openjdk-8-jdk

when i try install openfire on windows then use same database it succesfull completely. Database is hosted on my ubuntu VPS (which is i am unable to setup database when install openfire on ubuntu)

i think this is something in openfire i install in ubuntu

i install fresh too.
i used to succesfully setup openfire on ubuntu on previous version

Do you install via sudo dpkg -i openfire_4.3.2_all.deb?

tried all. sudo dpkg, install from tr.gz,

it all still same. stuck at infinite loading when setup mysql as database.

it work fine when i tried embedded database

Ah, so the installation of Openfire package is fine, but the error happens on the database connection page during web configuration step? Is it showing this error on the page itself or you have found it in the logs? You can check /openfire/logs/all.log for more clues.

In 4.3.2 MySQL connector has been updated to the latest version and it is more strict about timezones. There was a change in daylight saving settings recently and it has affected database connection string in some cases. Usually there is an error mentioning wrong TMZ setting. One can fix that by editing mysql config or adding proper timezone code to the database connection string.

ok. will try that. thanks for your kind response