powered by Jive Software

Ubuntu install pb : no acces to admin

Hello !

I steup a ubuntu on my new PC. I had before a debian sarge but i would like to try ubuntu. I tried to install a Wildfire server (i already have one on my debian) from the tar.gz. I try to access to the admin panel : http://127.0.0.1:9090/ but i got an error : page not found

The netstat -a | grep 9090 say me nothing It seems that the server do not listen. Thought, logs say : server listenning to 127.0.0.1:9090

Do not understand Do you have an idea ?

it’'s work, server does not start very well… I need to run wildfire start two time to run the server Anyway i will look about that later… now another pb : i cant register account : impossible to connect the host.

Hi,

do you run a local iptables firewall on the Wildfire server?

LG

Yes i got an iptables firewall but it is a very strange verion in ubuntu : no script in /etc/init.d/ to start iptables. I add a line in /etc/hostsand now i can connect from my server to himself but i can’'t connect from internet.

Do you have an idea ?

Hi,

are you using the ip address or a host name (xmpp domain or server name)? As I assume that your server is behind a firewall/nat-router and has a private address like 10.1.1.1 or 192.168.1.1 you need to configure your router to forward packets to port 5222 to your internal ip address:5222.

LG

Hi,

Port forwarding is already done using TCP only for 5222 port (no SSL right now ). I use in wildfire.xml 127.0.0.1 for parameter. Server name is my domain in DynDns.org.

I realy don’‘t understand why it’‘s doesn’'t work My router seem to be ok maybe it is iptables…

Hi,

do you use a router to forward port 5222 to your server? If you do this then you need to forward the packets from your “external” server interface (192.168.1.1 or something like this) to 127.0.0.1 as you did bind Wildfire to 127.0.0.1. It will not listen on 192.168.1.1, so the packets may reach your external interface but not your loopback interface.

You could also use a CM to bind to 192.168.1.1:5222 and connect to 127.0.0.1:5222. But with NIO a CM is not really needed any more.

==> Editing conf/wildfire.xml and commenting the interface section may resolve your problem.

LG