powered by Jive Software

Unable load ofmeet plugin on Openfire 4.0.4

I try to load ofmeet on Openfire 4.0.4. It couldn’t be loaded. Version problems or else?

Error:

at java.net.URLClassLoader.findClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

… 16 more

2016.12.15 16:48:11 org.jivesoftware.openfire.container.PluginManager - Error loading plugin: C:\Program Files (x86)\Openfire\plugins\ofmeet

java.lang.NoClassDefFoundError: org/jitsi/impl/osgi/framework/OSGiLauncher

at org.jitsi.videobridge.osgi.OSGi.start(OSGi.java:240)

at org.jitsi.videobridge.xmpp.ComponentImpl.postComponentStart(ComponentImpl.java: 469)

at org.xmpp.component.AbstractComponent.start(AbstractComponent.java:967)

at org.jivesoftware.openfire.component.InternalComponentManager.addComponent(Inter nalComponentManager.java:159)

at org.jitsi.videobridge.openfire.PluginImpl.initializePlugin(PluginImpl.java:205)

at org.jivesoftware.openfire.plugin.ofmeet.OfMeetPlugin.initializePlugin(OfMeetPlu gin.java:131)

at org.jivesoftware.openfire.container.PluginManager.loadPlugin(PluginManager.java :447)

at org.jivesoftware.openfire.container.PluginManager.access$300(PluginManager.java :68)

at org.jivesoftware.openfire.container.PluginManager$PluginMonitor.run(PluginManag er.java:1037)

at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)

at java.util.concurrent.FutureTask.runAndReset(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301 (Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknow n Source)

at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

Caused by: java.lang.ClassNotFoundException: org.jitsi.impl.osgi.framework.OSGiLauncher

at java.net.URLClassLoader.findClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

what version of ofmeet did you use? i just tested latest 0.3.38 withOF 4.0.4 and it worked ok for me

I verified ofmeet’s version, it’s 0.3.28. I can download it from here.

The last version is 0.3.38?

I solved this issue after re-install Openfire & ofmeet.

Good to know. Thanks