powered by Jive Software

Unable to configure ipv6 with windows2003

I have added ipv6 support to the Windows2003 OS, and have Openfire listening on all interfaces. However, Openfire is not listening on its ipv6 address, only ipv4. I am using version 3.6.2 using the “all-in-one” installer with the included JRE. Would installing my own JRE and just using the barebones executable work better? If it doesn’t work with win2k3, would I be able to install a secondary server running *nix which would enable ipv6 support? Let me know if I can provide anything in the ways of troubleshooting. What little information I could find said that as long as the host OS supports ipv6, everything should “just work”.

Thanks in advance

Hi Mattias,

you could try to set -Djava.net.preferIPv6Addresses=true, maybe this helps.

I always set -Djava.net.preferIPv4Addresses=true (;

LG

`

`

I created a file in the bin directory called openfire-service.vmoptions and put in the option -Djava.net.preferIPv6Addresses=true which did not make a difference.

EDIT:

Actually I lied, it did make a difference, it broke ipv4 connectivity

Message was edited by: Mattias Lindgren

More details, when doing a netstat -an I see:

TCP [::]:5269 [::]:0

So the box seems to be listening on the s2s port, but not on 5222.

Followup discussion: http://www.igniterealtime.org/community/thread/36598