powered by Jive Software

Unable to connect spark domain when spark account creation

Hi,

I installed Openfire 4.1.5 on amazon cloud server(os : windows server 2012 R2).

and create Active directory DNS (heyjae.com)

then installed spark 2.8.3 on the same server for test.

But whenever creating account with spark client, I failed with below message.

“unable connect to win-cjdus02sno3.heyjae.com

win-cjdus02sno3 is computer name and heyjae.com is dns name

this is my sysem property on openfire.

what to do I check?

Property Name
Property Value
adminConsole.port
9090
adminConsole.securePort
9091
connectionProvider.className
org.jivesoftware.database.EmbeddedConnectionProvider
locale
en
passwordKey
hidden
provider.admin.className
org.jivesoftware.openfire.admin.DefaultAdminProvider
provider.auth.className
org.jivesoftware.openfire.auth.DefaultAuthProvider
provider.group.className
org.jivesoftware.openfire.group.DefaultGroupProvider
provider.lockout.className
org.jivesoftware.openfire.lockout.DefaultLockOutProvider
provider.securityAudit.className
org.jivesoftware.openfire.security.DefaultSecurityAuditProvider
provider.user.className
org.jivesoftware.openfire.user.DefaultUserProvider
provider.vcard.className
org.jivesoftware.openfire.vcard.DefaultVCardProvider
sasl.scram-sha-1.iteration-count
4096
setup
true
stream.management.active
true
stream.management.requestFrequency
5
update.lastCheck
1499502416097
xmpp.auth.anonymous
false
xmpp.domain
** WIN-CJDUS02SNO3.heyjae.com **
xmpp.fqdn
** WIN-CJDUS02SNO3.heyjae.com **
xmpp.session.conflict-limit
0
xmpp.socket.ssl.active
true

What do you put into Spark’s domain field?

I put Spark’s domain field.

win-cjdus02sno3.heyjae.com, heyjae.com, localhost, 127.0.0.1, etc…

but it’s not work.

You should put win-cjdus02sno3.heyjae.com only as this is your xmpp.domain. But you only have hayjae.com in your DNS as i understand. So you need also win-cjdus02sno3.heyjae.com in your DNS. Or maybe you want your xmpp.domain to be hayjae.com and then have and SRV record pointing hayjae.com to win-cjdus02sno3.heyjae.com machine, see Configuring DNS for instant messaging

Also, first try just logging in with an existing account and see if that works. Then try creating accounts with a client (make sure you have enabled creating account in-band in Admin Console though).