powered by Jive Software

Unable to connect to the manager server

Hi All,

Could you all please help me out. I have gone thru all forum and have not found any solution on getting the Wildfire server to communicate to Asterisk Server.

Firstly i what i have done so far

  1. I Installed Wildfire IM - successful. Users are able to chat

  2. Downloaded the asterisk plugin, run it on the wildfire server - successful

  3. Downloaded Asteriskwin32, installed it on wildfire server (http://www.asteriskwin32.com/). Asterisk running successfully.

  4. from wildfire, selected Asterisk IM Tab, General Setting,

Enabled: YEs

Server: 202.12.1.22

Port 5038

Username: manager

Password: secret

After keying all relevant details, i got the error saying unable to established a connections to the manager server, please see error log.

Can anyone tell me what i have done wrong. I read one of the topics, said to change the manager.config but it still doesnt work.

I know many of you have got it up and running now, could you please help me out. Please let me know what info you need and i can post all details to help me solved my problems.

Here are the errors i got from the asterisk server log:- Hope this help

May 3 13:42:41 VERBOSE[2524]: == Parsing ‘’/asterisk/etc/manager.conf’’: May 3 13:42:41 VERBOSE[2524]: == Parsing ‘’/asterisk/etc/manager.conf’’: Found

May 3 13:42:41 DEBUG[2524]: 202.12.1.22/255.255.255.0/255.255.255.0 appended to acl for peer

May 3 13:42:41 DEBUG[2524]: 0.0.0.0/255.255.255.255 appended to acl for peer

May 3 13:42:41 DEBUG[2524]: ##### Testing 202.12.1.22 with 202.12.1.0

May 3 13:42:41 DEBUG[2524]: ##### Testing 202.12.1.22 with 0.0.0.0

May 3 13:42:42 VERBOSE[2524]: == Connect attempt from ‘‘202.12.1.22’’ unable to authenticate

I have keyed in the correct username and password, and it still say unable to authenticate. Create a diff users, still got the same error msg. Pls do help and i have heard alot of good things about asterisk and appreciated all your help.

Thank You all in advance

Jeff

Hi,

maybe http://www.jivesoftware.org/community/thread.jspa?messageID=105823&#106075 does help, can you login using telnet?

http://www.jivesoftware.org/community/thread.jspa?messageID=113548&#113548 contains a manager.conf file, does your one looks alike?

LG

Hi LG,

Here are my config. Its look similar to the link you showed me. When i telnet to asterisk server 5038, i am able to telnet in and it say Asterisk Call Manager/1.0

when type the username and password, i was able to login succesfully. it say success and authenticated accepted. Any more ideas? on where my problems lies?

(Manager.conf)

; Asterisk Call Management support

;

enabled = yes

port = 5038

bindaddr = 0.0.0.0

secret = immanager

;deny=0.0.0.0/0.0.0.0

;permit=209.16.236.73/255.255.255.0

read = system,call,log,verbose,command,agent,user

write = system,call,log,verbose,command,agent,user

permit = 202.12.1.22/255.255.255.0

deny = 0.0.0.0

(Sip.conf)

type = friend

context=default

username = 3000

host = dynamic

mailbox = 3000

dtmfmode=rfc2833

Message was edited by: f1ea