powered by Jive Software

Unable to create account? Strange log file error

I’ve recently installed the latest version of openfire, 3.7.1, and SparkWeb will no longer allow me to create accounts.

I am able to log in using SparkWeb, however the instant I attempt to create an account, I am greated by this lovely message - “Unable to create account.”

I searched my warning log files and stumbled across this message “User tried to authenticate with this server using an unknown receipient”. Is there a setting somewhere within SparkWeb’s index file, or is this server related. I can’t set this messenger server to live if persons whom can’t readily download programs (there are quite a few), are unable to make accounts.

Thank you in advance, I am certain that I am missing something fairly basic.

I have the same problem here my logfile:

2012.02.07 16:25:36 org.jivesoftware.openfire.IQRouter - User tried to authenticate with this server using an unknown receipient: testtettest

I found the error, see my answer here:

http://community.igniterealtime.org/message/220478#220478

After setting the xmpp.domain the registration works fine.

I finally found the location of where to edit the xmpp.domain under server manager and system properties. Changed the ip from 127.0.0.1 to localhost and also tried localhost.mydomain.com and still not able to log in. Any ideas? I also did a reboot after each one of those steps. I also verified the host name in my openfire OpenSuse Applicance I downloaded from igniterealtime.org which is set to;

IP Full-Qualified-Hostname

127.0.0.1 localhost

Located in /etc/hosts

Also Im hosting the sparkweb from a stand alone lamp install since I couldnt access the /srv/www web directory via the browser even after changing permissions for that directory on the OpenSuse Applicance.

Also pointed he sparkweb.html over to my openfire/opensuse server

{

return {

server: “172.16.42.40”,

connectionType: “socket”,

port: “5222”,

autoLogin: “false”,

policyFileURL: “xmlsocket://172.16.42.40:5229”

};