powered by Jive Software

Unable to create conference for ofmeet 0.3.28 on Openfire 4.0.3

Hello,

I have read multiple posts about similar problems with the setting up of ofmeet but can’t find the answer. I have the same problem on both Ubuntu 16.04 and CentOS 7.

I tried to follow the plugin documentation but my usecase is really basic, I don’t use any optional components. I have installed a fresh Openfire 4.0.3 with embedded DB and just installed after that ofmeet module.

At first I had a 404 when trying to open https://openfire:7443/ofmeet/?r=bb but a “systemctl restart openfire” corrected that issue.

Now, when I open a room, I can see my own camera but :

  • No one can join. When I give the link, the other person sees its own camera but that all

  • No conference is created in Openfire meeting summary http://openfire:9090/plugins/ofmeet/ofmeet-summary.jsp

  • When I click on “Share this link with everyone you want to invite” there is a message stating that the “Conference is currently being created” and Invite is greyed

  • Every few seconds, I get this message in openfire logs (but no “error”) and it doesn’t stop

2016.11.18 17:31:00 INFO [Jetty-QTP-BOSH-95]: org.jitsi.videobridge.openfire.Config - Config servlet

2016.11.18 17:31:14 INFO [Jetty-QTP-BOSH-57]: org.jitsi.videobridge.openfire.Config - Config servlet

2016.11.18 17:31:24 INFO [Jetty-QTP-BOSH-56]: org.jitsi.videobridge.openfire.Config - Config servlet

The log that can be extracted from the chrome session (meetlog.json) seems just “empty” of any useful information

{

“metadata”: {

“time”: “2016-11-18T16:32:28.639Z”,

"url": "https://xxx.xxx.xxx:7443/ofmeet/?r=bbb",

“ua”: “Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.99 Safari/537.36”,

“xmpp”: []

}

}

What am I missing ? I’ve read something about the configuration of ofmeet and the creation of the focus user but it seems to be necessary for previous version and doesn’t seem to apply with the latest from what I gathered from previous forum posts. Also I see the focus user in the console so I guess this works.

I’ve also read something about MUC rooms but I have absolutely no idea of what this is.

Can you help me ?

Have you tried to open https://server-IP:7443/ofmeet ?

Is Openfire a name resolved in a DNS server? or is it the name for the localhost?

Please confirm your focus user is the the MUC (multi-user-chat) room you are using along with all other participants.

Also confirm that the Meetings summary page show that a videobridge was created for he meeting and it reflects the name of the MUC room you checked.

If these are not confirmed then have a look at your openfire log files and check for any errors with Jitsi Videobridge. Logging was improved in version 0.3.28 and the errors that were going previously to stderror and stdout are now shown in openfire logs

Thank you both for your answer.

@william mahecha : The server is indeed resolved by DNS but just to be sure I checked with the IP adress and the result is the same

@dele olajide : I have seen nothing particular in the logfile unfortunately otherwise I would have copied it but I might not be looking at the good file. For the MUC,as I was saying I’m not really sure what I have to check.

I switched my openfire admin interface to english in case it’s obvious but I can’t see anything that looks like a “MUC menu”. Is it in the “Group chat / Administration menu” ? I don’t have anything here.

In the session-summary I see focus user is active/authenticated

In the plugin menu, I have no meetings at all in the summary as I stated in my initial post which is indeed a problem.

MUC is also known as Group Chat. Look at Group Chat | Room Settings and confirm you have more that 2 people in the room inclufing the focus user. Also confirm that your focus user has permissions to manage rooms by being a member of the Group Chat Administrators list.

In Group Chat / Group Chat Settings / Service summary

I have a subdomain “conference”. When I click on it I can see the options

focus user is indeed “Group Chat Administrators” of “conference”

there doesn’t seem to be anyone inside the Chat Room

Any progress? I ve got very simillar problem

Sadly no.

I have also tried to update to Openfire 4.0.4 and 4.1.0 after that, no improvement.

I also used the source from the github that I compiled my own JAR, no improvement. I even switch to the devel branch from the github repo.

Additionnal node : It was slightly better with the devel code if I remember correctly as the conference was now created in the plugin menu in Openfire. Chat was working but still no video feed (log stating as such).

As no one else (expect you) seemed to be having the same issue, I was wondering what could be triggering this issue in my environment. I have a very peculiar LAN topology so I was about to deploy it on cloud instance with the exact same procedure to see if there was a difference but I haven’t had time yet

Well, today I got it to work simply by adding the user focus to our LDAP and restarting service. Another problem poped out when more people tried to connect to conference room and just two of us could see each other. In order to work I only changed bitrate of A/V so some limit, for me 96/512 was a good compromise and also lowering resolution to 640. Thats all I did and after next service openfire restart it worked flawlessly.

Good to hear!! Sometimes I wonder if I am the only person for whom it works most of the time flawlessly

If your LAN is non standard, look at the changing the public and private IP addresses in the meetings settings or the range of ports. At the end of the day, the openfire and chrome log files are your friends in situations like this. Take a closer look at any severe errors or warnings.