powered by Jive Software

Unable to log in to Spark after Domain Admin PW Change

Summary of problem: I changed the domain administrator password, now everyone gets “invalid username or password” when trying to log in to Spark.

Detailed description:

  • We have a terminal server with about 10 users. Spark 2.6.3.12555 is installed on the terminal server.
  • The client settings are

  • We have Openfire 3.6.4 installed on a SBS server
  • “openfire” service on the sbs server was set to automatic and was started. The service logs in as “local system”
  • there are no services on either server which say they use the domain admin credentials to login
  • All services with start=automatic on the SBS server and the terminal server are started
  • I changed the domain administrator password, now everyone gets “invalid username or password” when trying to log in to Spark
  • I restarted the openfire service. Same problem
  • From terminal server, I was able to telnet sbsservername 5222 and I got an answer, so I don’t think windows firewall is the problem

Anyone have any troubleshooting steps to try? I want to avoid rebooting the sbs server

Andrew

Its likely the account used for LDAP lookups within openfire, was also the account password you changed. Id recommend not using a domain admin account for ldap lookups, as its not needed. by default, authenticated, non-privileged accounts should be able preform limited ldap lookups.

However, you’ll need to regain access to openfire admin portal and update the username/password used for your ldap lookups.

you can do this by re-running the setup wizard. Another option maybe to reset the admin password back to what it was, sign into openfire admin console, make the changes using the gui, then perform your password reset again.

also, you might look at upgrading spark and openfire!

Thanks for the reply!

You were right, Openfire was using the domain admin for LDAP queries. I used your idea to fix the problem. I changed the domain admin password back to what it was before. Then I was able to go to the admin portal http://localhost:9090. I logged in and went to the system properties section. There was a property named ldap.adminPassword with the old password. I changed this to the new password. I know this isn’t best practice and I should use a separate account, but I just wanted to get them up asap. I changed the domain admin password back to the new password. I restarted the openfire service. Now Spark works for all clients.

Andrew