powered by Jive Software

Unable to log in to web admin panel using AD creds

I am not able to log in to web admin on http or https. I am just getting login failed, check username/password.
the server is windows2012, openfire 4.2.3, AD integrated.

I verifed that the admin users are listed in the database but the logs just show

2020.02.10 13:36:06 org.jivesoftware.admin.LoginLimitManager - Failed admin console login attempt by xxxxxx from xx.xx.xx.xxx

For this installation, did this work before, or did you install everything from scratch, and are you having trouble to set it up?

This worked before right after install and original configuration. It stopped working over time. We don’t need to log in frequently and did not notice the issue until now.

This is what I suggest:

  1. Ensure you have proper backups of Openfire and the database
  2. Shut down Openfire
  3. Edit openfire.xml, find the setup tag, and change its value to false.
  4. Restart Openfire
  5. Access the admin console, which will now give you the setup wizard which will show your original settings, instead of the post-installation admin console
  6. Make changes / test settings where needed.
1 Like

I will try this after hours today. thanks.

This worked and now I am able to login using the set admin credentials.