powered by Jive Software

Unable to Log Into Admin Portal

Hello,

I am unable to log into the admin portal for the openfire install after restarting the service. I was able to prior to that and it was reading my AD admin credentials fine. I restarted the service but am unable to log back in as an admin.

CentOS7, fresh install.

Help?!

Thanks,

Shane

same here… fresh install cannot open admin portal. why ?

My guess is that you are hitting OF-1331, so try from an ‘incognito’ new browser window or restart your web browser prior to attempting to log in?

Already try to use mozilla with Private Browsing still can’t open admin. Then how to resolve this ?

Are you using admin as the username to log in as? Otherwise, you need to provide more information on what you tried, etc. Are you running the service as an Administrator on windows?

i’m installing with ubuntu OS. after fresh OS, and install java dan openfire, I can’t open http://myip:9090

Are you actually running Openfire after installing it? Also, if you try to access it from the same machine you have installed it on, use http://localhost:9090

I’m installing in dedicated server. Step by step like this

sudo apt-get update
sudo apt-get install openjdk-8-jre
wget openfire4.1.5.deb
dpkg -i openfire.deb

after that reboot my server. then I try to access http://myipaddress:9090 and I can’t acces it.
Last time I alwyas install openfire and, it always sucess. I already install openfire 10 times. And it’s work. But why now I cannot install openfire in dedicated server ? I can’t access localhost:9090 because I install openfire in my dedicated server in europe.

Thank you

I’m not that familiar with Linux and Linux versions of Openfire, so not sure if something has changed about the startup scripts. But maybe something has changed in your dedicated server provider setup.
Make sure Openfire is running after you reboot the server (ps aux | grep openfire). Make sure something is listening on 9090 port (netstat -a). Make sure your dedicated server has no firewall/selinux enabled, try to temporarily disable it.

I have just tried to install latest deb on Ubuntu. After rebooting the server Openfire started (i can see it in the processes and i see one connection listening on 9090). I wasn’t able to test remote connection as it is an isolated virtual machine. But to disable a firewall i had to use ufw disable (on Ubuntu).

P.S. after switching to bridged network i was able to connect to Openfire’s setup remotely. When i have enabled firewall, i wasn’t able to connect again. So this might be a firewall issue.

how to to this ? do you any tutorial for this ?

This is not related to your problem, this is only important in the local virtual environment like in my case. I was only pointing out that it general it works and should work in your case. Just check all the things i have listed (processes, listening port, firewall, selinux, etc.)

i my server, i firewall always off. but i still cannot login to admin panel. Already try to install 4 new server but all my openfire cannot open admin panel. but if i move old database, i can login to admin panel.

I already solve this problem.

How to solve this ?

  1. open openfire.xml
  2. change port 9090 and 9091 to another port
  3. uncomment <— in network and —>
  4. change the ip 127.0.0.1. become your server ip
  5. service openfire restart

then now you can open admin area.