powered by Jive Software

Unable to login in to Openfire with spark

Hi,

I’m not sure if this belongs here or in the spark discussion as I have seen discussions in both so I apoligize in advance if this is in the wrong place.

My situation :

I have just installed Openfire 3.6.4 on a Fedora Core 11 box using a basic install and following the install instructions posted with the download of the rpm. I am able to login to the server admin console as admin via *servername:9090. *I set it up to use the imbedded database as I only have about 4 or 5 people who will be using this so any other database integration would be too complex for the situation.

I have created 4 user accounts via the admin console and set one of those as an admin as well. I am able to use that account to login to the admin console as well.

However, when I attempt to login via the spark 2.5.8 client I get a user id/password invalid message.

Here is an excerpt from the error log:

at java.net.PlainSocketImpl.socketBind(Native Method)
at java.net.PlainSocketImpl.bind(Unknown Source)
at java.net.ServerSocket.bind(Unknown Source)
at java.net.ServerSocket.(Unknown Source)
at org.jivesoftware.openfire.net.BlockingAcceptingMode.(BlockingAcceptingMod e.java:35)
at org.jivesoftware.openfire.net.SocketAcceptThread.(SocketAcceptThread.java :57)
at org.jivesoftware.openfire.spi.ConnectionManagerImpl.createServerListener(Connec tionManagerImpl.java:144)
at org.jivesoftware.openfire.spi.ConnectionManagerImpl.createListeners(ConnectionM anagerImpl.java:84)
at org.jivesoftware.openfire.spi.ConnectionManagerImpl.start(ConnectionManagerImpl .java:826)
at org.jivesoftware.openfire.XMPPServer.startModules(XMPPServer.java:569)
at org.jivesoftware.openfire.XMPPServer.start(XMPPServer.java:434)
at org.jivesoftware.openfire.XMPPServer.(XMPPServer.java:161)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
at java.lang.reflect.Constructor.newInstance(Unknown Source)
at java.lang.Class.newInstance0(Unknown Source)
at java.lang.Class.newInstance(Unknown Source)
at org.jivesoftware.openfire.starter.ServerStarter.start(ServerStarter.java:106)
at org.jivesoftware.openfire.starter.ServerStarter.main(ServerStarter.java:51)
2009.10.23 07:35:57 [org.jivesoftware.openfire.spi.ConnectionManagerImpl.startServerListener(Connec tionManagerImpl.java:172)] Could not setup a server socket
java.lang.NullPointerException
at org.jivesoftware.openfire.spi.ConnectionManagerImpl.startServerListener(Connect ionManagerImpl.java:163)
at org.jivesoftware.openfire.spi.ConnectionManagerImpl.startListeners(ConnectionMa nagerImpl.java:126)
at org.jivesoftware.openfire.spi.ConnectionManagerImpl.access$000(ConnectionManage rImpl.java:54)
at org.jivesoftware.openfire.spi.ConnectionManagerImpl$1.pluginsMonitored(Connecti onManagerImpl.java:108)
at org.jivesoftware.openfire.container.PluginManager.firePluginsMonitored(PluginMa nager.java:533)
at org.jivesoftware.openfire.container.PluginManager.access$800(PluginManager.java :47)
at org.jivesoftware.openfire.container.PluginManager$PluginMonitor.run(PluginManag er.java:1042)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask$Sync.innerRunAndReset(Unknown Source)
at java.util.concurrent.FutureTask.runAndReset(Unknown Source)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101 (Unknown Source)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodi c(Unknown Source)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknow n Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
2009.10.23 07:35:57 [org.jivesoftware.openfire.spi.ConnectionManagerImpl.startClientListeners(Conne ctionManagerImpl.java:359)] Could not setup a server socket
java.net.BindException: Address already in use
at sun.nio.ch.Net.bind(Native Method)
at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source)
at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source)
at org.apache.mina.transport.socket.nio.SocketAcceptor.registerNew(SocketAcceptor. java:363)
at org.apache.mina.transport.socket.nio.SocketAcceptor.access$800(SocketAcceptor.j ava:55)
at org.apache.mina.transport.socket.nio.SocketAcceptor$Worker.run(SocketAcceptor.j ava:222)
at org.apache.mina.util.NamePreservingRunnable.run(NamePreservingRunnable.java:51)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

I don’t understand why I can login through the admin console but cannot with the client. the client is using the default settings. Also should it be connecting via port 5222 or 5223. 5222 shows in the client under advanced settings but there is no 5222 setting that I can see in the openfire admin console.

Any help would be much appreciated.

Thanks

Dan

I have an update.

Under advanced options on the spark client I checked off the option to use “old ssl” port method then I was able to connect on I assume port 5223.

What gives with that? What does old ssl port method mean?

thanks

You would use port 5222 if you are not using ssl, 5223 if you are. As for the SSL methods i cannot explain the differences.

I have the same problem. Original Openfire ver was 3.3.2 and upgraded to 3.6.4 and now all users can’t login to openfire.

They are all using Spark to connect.

rolled back to ver 3.3.2 and still having the same problem.

tried pandion as well, same problem. using port 5222.

enabled the debugger on spark and got this error:

deenak

ok. getting somewhere now… I changed the port on openfire from 5222 to 5225 and setup spark to use 5225 and it worked!

now to try and figure out what process is holding up port 5222. will post back once I find out.

Hey there,

This post saved me, lol. Yeah, I noticed that port 5222 reported that it was listening and responding. However, I could never connect. I was taking some heat. I thought about changing the port but I was too busy scanning the log files trying to find exactly what the problem was…I am still confused and I would love it if someone could explain this phenomenon.

I just now changed port 5222 to 5225 as well and it did the trick!

This is a very strange problem indeed.

Hopefully someone can explain this to us.

Dan

to tell you the truth never really went back and investigated. i just sent out a bulk mail to all users to change the port on the client. but i think i’ll look into it. would be nice to get to the bottom of it. don’t want to have the same problem the next time we upgrade openfire.