Unable to login to Admin Console

Hi All,

I am after a little help if possible. I will keep this short and sweet!

I have inherited Openfire Ver. 3.6.4 running on a SQL database and I am unableto log in to the Admin console. I have searched the boards here and found multiple ways of getting round this issue. The first way was adding a new user entry in to the SQL database and secondly re running Openfire setup and create a new Admin password. I can see that the setup updates the entry in the database as I changed the admin email address.

My question is simply is there anything else I can try in order to access the admin console? Even changing the password through setup does not allow me to access the console. I keep getting username and password is incorrect.

Thoughts are very much appreciated and I am sure I will need to provide you more information.



Are you using username “admin” to login? New users get confused and use admin’s email instead.

Hi wroot,

Cheers for your advice. I have been trying the user admin. I can get in to the user table in SQL and see the admin user present. I have also tried running openfire setup again on a different PC and pointing to the SQL database for users. I changed the admin password and default email address and I could see it update in the SQL database.

Its a little odd, when I run through setup it asks for the admin previous password before I can change it and regardless of what I enter in the previous password it lets me carry on through the install. Its almost as though Openfire is not interrogating the database for users and passwords.

Has anyone seed this before?

Thanks again

As i usually set the same password when i test rerunning the setup i have never noticed how it behaves when you specify wrong previous password.

Yeah that makes sense. I am thinking I will try and intergrate with AD using LDAP.

Just frustrating how I am unable to login to the Admin console with the current setup.