powered by Jive Software

Unable to login to jabber server using clients

Openfire installation went fine, logged in to admin console on localhost:9090.

Then I tried logging in with the admin user with a client, but Openfire wouldnt auth me. I tried gnu-freetalk, mcabber, pidgin and psi. All of them gave a variant of the “bad username/password” error message.

I went back to the admin console and created a second user, thinking that maybe you arent allowed to login with admins or something. But neither that user was granted access when trying to login.

I then went to “server -> server settings -> registration and login” and enabled “Inband Account Registration” to see if it was something wrong with the admin consoles way of creating users. I fired up Psi and tried to create a user, using its wizard, but got the message that the server dont support user registration. Also tried with gnu-freetalk by just logging in with new credentials, because as Ive understood it, that will create a new user? Anyway, no luck.

Im unsure on what to try next. Im also a bit unsure on what info to provide, im more used to textbased config files, hard to pastebin the settings when its a webbased interface.

can you try stopping openfire and see and check if there is another xmpp server running? happened to me when i tried installing openfire and didnt know that there another jabber server is already running.

Hmm, you might be on to something here. I had forgot I tried the basic jabber daemon before openfire. A quick “sudo /etc/init.d/jabber stop” killed it.

Trying to login with "admin@mizipzor.homelinux.com" gave the error:

"There was an error communicating with the server.

Details: XMPP Stream Error: Generic stream error"

Pidgin gave a simple “Stream Error”.

Freetalk didnt give any error, but after logging in with both the testuser and admin I fail to make them send anything to each other.

Although, I consider this progress.

Tried today at work on my windws box with a miranda client. It simply wouldnt connect, couldnt find any error messages or anything.

Asked a coworker that works in osx to try it with the Adium client. It to stated a “Stream error”. But only after I manually created a user for him, inband creation of users still doesnt work.

Does anyone have anything that I could try? Like getting more detailed information about the error from the server or something?