powered by Jive Software

Unable to verify the certificate

While using spark to connect openfire server. it’s showing unable to verify the certificate. I don’t know what to do. If anybody help me… it’ll b better to me guys.

Open Advanced menu on the login screen and check the Accept all certificates option.

after check that “Accept all certificate” option, I try to login. it’s showing error like “Unknown connection error”

Are you using IP address in this Domain field?

yeah, actually, my openfire info is…

Server Properties
Server Uptime:
1 hour, 47 minutes – started May 3, 2017 9:17:25 AM
Version:
Openfire 4.1.3
Server Directory:
D:\ProgramFiles\Openfire
XMPP Domain Name:
mindnotix
Environment
Java Version:
1.8.0_121 Oracle Corporation – Java HotSpot™ Client VM
Appserver:
jetty/9.2.z-SNAPSHOT
Server Host Name (FQDN):
mindnotix
OS / Hardware:
Windows 8.1 / x86
Locale / Timezone:
en / India Standard Time (5 GMT)
OS Process Owner:
Admin
Java Memory



29.69 MB of 247.50 MB (12.0%) used

i used this domainname too. it’s not working.

You can read my guide i have posted recently. Very Basic Openfire + Spark Guide [EN] – /w/root

Especially 4 and 5 chapters. The last bullet chapter has an option which should work for you - putting domain name mindnotix into Domain field and IP address into Host field on the Advanced menu.

May be your IPTABLES BLOCKED. use service iptables stop and change selinux disabled. or else allow 5222 (default spark port number) port. thank you.

while connecting client. use Advanced --> tick accept all certificate and tick disable certificate hostname verification. then login