Unix installation

Hi All,

I follow intallation instruction, to install wildfire on a Sun Sollaris box.

When i tried:

“tar -xzvf wildfire_3_0_1.tar.gz”, it ends up with an error say “tar: z: unknown function modifier”.

To overcome the problem i use gunzip command to unzip “wildfire_3_0_1.tar.gz” to “wildfire_3_0_1.tar”

then “tar -xzvf wildfire_3_0_1.tar”, this time it is unpacked properly with no error. But when i look into the

subdirectory wildfire/lib, there is no “wildfire.jar” file but “wildfire.jar.pack”, i tried to unpack the “wildfire.jar.pack” but to no success. As i need to modify some wildfire code and do a build for unix, i need to be able to replace the wildfire.jar file with the one i build. Can i have some help on this.

Very much appriciated,


I don’'t know how much this will help, however, when I do wildfire installs on my gentoo boxen, I use the following commands to unpack the tarball:

  1. gunzip wildfire_3_0_1.tar.gz

  2. tar -xvf wildfire_3_0_1.tar

the -z option for the tar command gzips (or gunzips, in this case) the archive. Running “gunzip (file)” before “tar -xvf (file)” does thesame thing.

You may want to blow away the created directory and source tarball, and try re-downloading wildfire, and then running gunzip and tar.

donwnload again the file and use.

gzip -dc wildfire_3_1_0_beta_2.tar.gz | tar -xvf -

Hi Trung,

just start Wildfire, it will then unpack the .jar.pack to .jar files. Using .jar.pack files enables a better compression and the jivesoftware.org guys like it.


Hi all,

Once again, many thanks. Everything is working now :-).