powered by Jive Software

Update Openfire on Ubuntu

Hi all,

I downloaded the 3.9.1 .deb file

Then entered the following command in the terminal: sudo dpkg -i openfire_3.9.1_all.deb

But got the following error:

Selecting previously unselected package openfire.
dpkg: regarding openfire_3.9.1_all.deb containing openfire, pre-dependency problem: openfire pre-depends on sun-java5-jre | sun-java6-jre | default-jre-headless | openjdk-6-jre
  sun-java5-jre is not installed.
  sun-java6-jre is not installed.
  default-jre-headless is not installed.
  openjdk-6-jre is not installed.
dpkg: error processing openfire_3.9.1_all.deb (--install): pre-dependency problem - not installing openfire
Errors were encountered while processing: openfire_3.9.1_all.deb

When I do java -version I get: java version “1.7.0_51”

OS is Ubuntu Server Edition 12.04 LTS.

I am assuming my Java version is not the right one.

Can I simply install an older version of Java? What do you recommend me to do ?

Thanks!

The dependencies should be updated to support Java7. I’ve filed this as: OF-741

For rpm / RHEL one would use the --force parameter to install it anyway. I assume there’s something similar for dpkg. The start script should find your java 7, I hope.

The 3.9.1.deb seems to be broken with even a fresh install of Ubuntu 12.04 and OpenJDK-6. See my post here:

If you get 3.9.1 running on 12.04, please respond to my post.

Thanks.Peet

I found that even after those errors the package installs. I installed my Oracle Java from the Webupd8 PPA as described here -

The problem is that the init script provided with the package is missing the path to this Java install so I needed to edit /etc/init.d/openfire and add this, " /usr/lib/jvm/java-7-oracle" to the end of JAVA_HOMES.

Attempt to locate JAVA_HOME

if [ -z $JAVA_HOME ]; then

JAVA_HOMES="/usr/lib/jvm/default-java \

/usr/lib/jvm/java-7-sun \

/usr/lib/jvm/java-6-sun \

/usr/lib/jvm/java-1.5.0-sun \

/usr/lib/jvm/java-7-openjdk-amd64 \

/usr/lib/jvm/java-7-openjdk-i386 \

/usr/lib/jvm/java-7-openjdk \

/usr/lib/jvm/java-6-openjdk-amd64 \

/usr/lib/jvm/java-6-openjdk-i386 \

/usr/lib/jvm/java-6-openjdk \

/usr/lib/jvm/java-7-oracle" # This line added

Now Openfire starts for me.