powered by Jive Software

Updated to 4.3.2 and get this error when lauching admin portal


#1

java.lang.NoSuchMethodError: org.jivesoftware.openfire.auth.AuthFactory.isOneTimeAccessTokenEnabled()Z

Any ideas on what to try ?


#2

From what version have you updated and what OS are you using? Also do you use bundled Java or install your own Java? What version?

Check /openfire/plugins/admin/webapp/WEB-INF/ folder. If you have lib folder in it, delete it. There should be more errors than that. Check /openfire/logs/all.log for more insights.


#3

Thanks for your response. I was going from 4.2.3 to 4.3.2. I was able to get the error resolved since posting this thread. When I originally ran the update executable, openfire was still open in the background which resulted in an error midway through
the install. It did install, but I once I received this error I reran the update with openfire properly closed and that resolved my issue.

Thank you,

Tyler Asbell