Upgrade database manually


How do I upgrade the openfire database manually so that I could use asterisk-im plugin? It’s showing the following messages:

Found old database version 0 for asterisk-im. Upgrading to version 2…

asterisk-im - Database update failed. Please manually upgrade your database.



Which database do you use? I.e. embedded, MySQL, …?

opsssss… Forgot to say that…hehehehe

Oracle Database 10g R2

You can manually apply the upgrade scripts through sqlplus:

http://svn.igniterealtime.org/svn/repos/asterisk-im/trunk/server/src/main/databa se/upgrade/1/asterisk-im_oracle.sql

http://svn.igniterealtime.org/svn/repos/asterisk-im/trunk/server/src/main/databa se/upgrade/2/asterisk-im_oracle.sql

At least one of them ill probably fail so you have to fix the SQL. Please report back what you had to change so I can include it for future versions of Asterisk-IM.

Hey guys, thanks for the thread, and thanks for letting me jump in here too. I have the same issue, but I am using mySQL. Is there a URL for me (& any one else) for us? Or is the SQL similar enough to just run it against the mySQL db? (it looks as if it might be but I’m not ertain & dont want to bork a production server)

Thanks so much.


Message was edited by: support@sjobeck.com

I made a back-up & jsut went for it. I ran the SQL against mySQL & it ewnt through clean, said it affected two rows & no duplicates & seems fine.

I restarted the daemon & same error when I tail the error.log file.

Can I just dump this table & recreate it empty?

Thoughts? Adive? SQL code/query? URL?

Thanks much!


i’m getting a similar problem using the embedded DB - any way to inject this in there?

nvm - i found the .sql edits i needed to make to fix it…