powered by Jive Software

Upgrade Openfire

Hello.
I’m using “Openfire 4.0.2” and I want to upgrade it to the last version, but can it cause any problem like to define my users again or…?

Thank you.

Usually there shouldn’t be problems upgrading with new version on top of older one. Read the http://download.igniterealtime.org/openfire/docs/latest/documentation/upgrade-guide.html
Of course, do backup first. As you are using quite old version, you might need to do incremental upgrades version by version instead of to the latest version at once. You can find older versions here https://github.com/igniterealtime/Openfire/releases

I stopped “Openfire” and run “openfire_4_2_3_bundledJRE_x64.exe” but I got below error:

Screenshot-10

Clicked on “Cancel” button and run setup again and “Openfire” installed but when I want open admin console then I got below error:

How can I solve it?

Are you an administrator on that machine? You can try stopping Openfire and run the installer again with Run as admin option. Also, i think your old version was 32-bit, but you have installed 64-bit version. When running the installer you had to manually point to the old installation folder? Or maybe you just installed as it showed by default? Then you have just installed a fresh install of Openfire 64-bit and your old installation is still there (in Program files (x86) probably). In that case uninstall the new version (run uninstaller in Program files\Openfire) and then try to install 64-bit version again and this time point to C:\Program files (x86)\Openfire. It will still install the 64-bit version, although it will stay in not 64-bit Program files folder, but that’s a minor thing i think.

Yes, The installer detected it automatically and asked me about “Upgrade” and uninstalled “Openfire” automatically but I got the first error. I run setup again and it is installed in “C:\Program Files\Openfire”. How can I solve this problem?

Did it install into C:\Program files\ or C:\Program files (x86)\ ?

If on your second try it installed into C:\Program files\Openfire, go there and run the uninstaller. Then run the installer again via Run as administrator. If it doesn’t detect your old installation in C:\Program files (x86)\Openfire, then point it manually to that folder and install\upgrade again.

New Openfire version installs and runs a service by default. So after the installation don’t run the Launcher. Just go to http://localhost:9090 in your browser.

It is installed in “C:\Program files”. I can’t fix this problem with x64 version?

I have already provided you steps to try. You seem to not read carefully what is suggested to you…

Do you understand what Run as admin means?

Have you tried to uninstall Openfire from C:\Program files\Openfire (there should be the uninstall.exe file)?

After uninstalling it from Program files, have you tried installing it via Run as admin into Program files (x86)\Openfire?

Thank you.
I just uninstalled and reinstall it to “C:\Program Files (x86)\Openfire” and problem solved.