Upgrade to 2.0.1 breaks sound and flashing taskbar

Hi everyone,

I successfully upgraded all my Spark clients to 2.0.1 with no installation problems. I have one problem though. Unless you run the program as an administrator, the sound settings will not appear or work in the preferences menu, and when a user receives a new message, their task bar will not flash.

If you run the program as an admin, these things do work. I tried playing with permissions on the Spark directory, but didn’'t have any luck. Is this a bug with 2.0.1? Anyone else having this problem?



I forgot to mention what system…I’'ve not yet had enough caffeine.

Windows XP SP2 clients.


Set the permission on Spark folder to allow users read / write access … you can just do the plugins folder if you wish and all should work fine. See the post below.


Thanks, that worked. As the other post mentions, however, I think I’‘ll hold off until the next version to see if this bug is fixed. I’'d rather not give normal users modify read/write permissions to anything in C:\Program Files. Thanks for the response though!!


Hi All,

What is the best way to prohibit read/write access on those directories? I googled for a solution but came up empty handed. (Windows XP)



Via the command line. Once you perform the GUI portions, you can always call on cacls.exe, which will allow you to manipulate the permissions of a directory directly from the command line.

There are all sorts of options, but if you want to add or remove certain ones while leaving the remaining, be sure to use, the /E switch.

If you want additional information on the command, please let me know.

So I’'m having trouble reproducing this issue by making everything just read only. What are the properties on the directory that are causing these directly?

Want to repro and fix asap.



For the C:\Program Files\Spark directory, I have the following:

Regular users:

Full Control = No

Modify = No

Read & Execute = Yes

List Folder Contents = Yes

Read = Yes

Write = No

This is what’‘s causing me grief. Everyone else having the same results? Checking modify giving the normal user this right fixes the issue, but I don’'t like this resolution for myself anyways.


Did you modify the default windows permissions to follow a security template or best practice? Is the issue far less complicated? IF you changed the default persmissions and expect the product to work, thats different then the product not working under default conditions.

If you have to lock down your directory, there might be some after install script that can run, to open the permissions just enough to allow proper use.

I didn’‘t modify any permissions initially, only after things weren’'t working and I posted in here and was told to modify permissions to elevate normal user rights, did I go ahead and do so. By giving the normal users group modify permission on C:\Program Files\Spark, it then allowed the taskbar flash and sound settings to function properly.

For myself, it’‘s just best practice for my work environment. We don’‘t give anyone modify or write access above and beyond what is necessary in C:\Program Files. I’‘m assuming nothing bad would happen by opening it up a little to allow users to have write access in here, but for me I’‘ll ignore the problems until this gets resolved in a new version. It’'s not a big enough problem to sweat about.

I think this addresses your second statement:

“IF you changed the default persmissions and expect the product to work, thats different then the product not working under default conditions.”

I have never touched any permissions in regards to default created permissions the Spark installer creates when you install the product.

Just to clarify, the permissions I posted above to the other user, are the ones that Spark created and set up during installation and running of the Spark launcher.



Message was edited by: btmanmeh

I do know that Microsoft changed their default permissions to be more restrictive in windows xp sp2, with that being said, the Spark dev folks might need to open a few things up after the install runs… I know my install of spark went well, but I also forgot I am a domain admin, so its a non issue. Would be interesting to see what would happen with a regular user.

Same deal here as well. I tested this with my IT department, and naturally none of us had issues because we’‘re domain admins as well. So, I went ahead and rolled this out to the users. I run solely Linux for my personal desktop machine(s) and also haven’‘t had any issues, but we run XP for the desktop users. I guess next time I should run things as a normal user before rolling a new version out. I’‘ve been running Spark and Wildfire for over a year now, and haven’‘t had a problem before so I guess I wasn’'t testing things as stringent as I should. After you have a wonderful product that works so well as this does, then perhaps a bit of complacency crept up on me.

Fortunately, it’‘s not a huge issue right now, because everything works ok. It’‘s just the users don’‘t get their pretty little blinking taskbar and sounds when new IM’'s are sent their way.

Like I said before, I’‘m sure this was probably a mistake on the developers parts. We’'ll wait and see what happens with the next version! Thanks for such fast responses though!



Well I’'ll be darned. I see the issue.


Fixed it.



Sweet, thanks Derek!


Might I ask, what you found?

Indeed you may The logging mechanism was trying to log to the logs directory throwing an unhandled exception and causing many items not to load. I’'ve changed the logger to log to the users home and added more exception handling, just in case.



Derek, thanks for the info and great job on tracking that down!

Might I trouble you for a round about date for release of 2.0.2.? Reason I ask is because I didn’‘t realize the broadcast plugin wasn’‘t working for my users either, which I just discovered. If you’‘re planning on rolling out 2.0.2 very very soon, I won’‘t bother editing user rights, but if it’‘ll be a few weeks or so, I’'ll go ahead and elevate their rights. We use the broadcast plugin pretty extensively. Thanks again for tracking this down so quickly! Keep up the good work!

I checked on the cacls.exe command, but didn’‘t see where it allows editing group rights, only specific user accounts. I use domain accounts across Samba from Linux so I don’'t see where I can easily edit this from the command line of Windows, so it becomes a PITA to have to log into 45+ machines and edit rights locally on the machine across a GUI, thus the reason for maybe an approximate release date of 2.0.2.



Just for a little FYI, I found a Windows Resource Kit tool called subinacl.exe which will allow you to control permissions from a user or group level. It’‘s much more powerful than cacls.exe. It’'s not installed on XP SP2, though so can you can get it from Microsoft here:

http://www.microsoft.com/downloads/details.aspx?FamilyID=e8ba3e56-d8fe-4a91-93cf -ed6985e3927b&displaylang=en

I know it’'s a bit late with this since Derek already traced the problem down, but none the less this easily allows me to change permissions until the new release is available. I figured I would share.