powered by Jive Software

Upgraded from 3.2 to 3.31 Home not found error?

Hi, I followed the upgrade exactly from the http://wiki.igniterealtime.org/display/WILDFIRE/WildfireUpgradeGuide and get this error after start up on :9090

Home not found. Define system property “openfireHome” or create and add the openfire_init.xml file to the classpath

Seems from the forums may be an ownership issue. I changed the owner from daemon and no change. Uninstalled and started over. Saw where that may not have been the issue. Not sure where to go. Now my company is without a chat server since Thursday night. I am using an oracle db. I could care less if I have to clean install this without the old data but that didn’'t seem to work either. same error. Please help, thanks

Hi,

it may also be an issue with the start script, that it fails to set “Openfire Home”.

I did post an installation guide here: http://wiki.igniterealtime.org/display/WILDFIRE/LinuxInstallationGuide because I had a lot of problems with the start script, detecting Java and Openfire Home.

LG

Got the same error, did a " chown daemon:daemon conf/openfire.xml " and it started working again, in previous install the config file was owned by jive:jive.

1 Like

I just did the same thing to mine, changed ownership to daemon:daemon and it fired right up! go figure…!!!