Upgraded to 3.6.2 but still shows 3.6.0

Hi all,

I just upgraded my server from 3.6.0 to 3.6.2, but on login page and on server confs still shows 3.6.0. I run openfire on a Ubuntu 7.10 server with sun-java6-jre (6-03-0ubuntu2).

root@marte:/etc/openfire# dpkg -l | grep java
ii java-common 0.26ubuntu1 Base of all Java packages
ii sun-java6-bin 6-03-0ubuntu2 Sun Java™ Runtime Environment (JRE) 6 (ar
ii sun-java6-jre 6-03-0ubuntu2 Sun Java™ Runtime Environment (JRE) 6 (ar
root@marte:/etc/openfire# dpkg -l | grep openfire
ii openfire 3.6.2 A high performance XMPP (Jabber) server.

What’s wrong? Best regards,

Marcio Merlone

My guess is that the upgrade did not fully work. I would try the process a second time.

I agree. So much that at the first attempt, when it did not work as espected, I did aptitude remove openfire (not purged) and dpkg -i openfire_3.6.2_all.deb once and twice again. Just did not aptitude purge in order to don’t loose configuration. I stopped the service and checked with dpkg -l | grep openfire before each attempt.

Next guess?

Marcio Merlone

I wonder if there is not an error in the linux installer for openfire that you are using.

you could always pull down the tar file and do a manual upgrade.

I could, but that screws up the server administration and future upgrades.

Ok so download the tar file extract it, and copy and replace everything except the conf folder and the folder for the embedded db. You already tried to do this via the installer. I do not see how this would affect the server adversely.

Ok, I see what you mean. I’ll try it later and post results.