powered by Jive Software

Upgrading from 3.6.2 to 3.6.3 never finishes

Hi,

Running Openfire 3.6.2 on Windows Server 2003 SP2.

I have tried to upgrade to 3.6.3 but the setup never goes past “Uninstalling previous version”. I have waited for about an hour but nothing seems to happen. Is there any way to see what’s happening, can I start the installer in debug/log mode?

As far as I can see, the bin directory has been deleted so some file operations have been performed.

/Daniel

Have you tried to kill it and start again? I think it should install fine then. Openfire was doing the same for me some time ago on almost every upgrade (WinXP box). But i havent seen such problem for a while now (maybe a year). 3.6.3 upgrade went smooth for me.

did you stop the old openfire server first. You should do this. Windows has a hell of a time with stopping openfire processes for some reason.

Yep, I’ve tried that a couple of times, no improvement. The first time I let it run for about an hour, but it never goes beyond “uninstalling previous version”.

Yes, the service was stopped every time. I even tried changing the startup to manual, reboot the server, try upgrade and it still doesn’t finish, “uninstalling previous version” and nothing happens.

I’m back to 3.6.2 again (made a backup of the install folder before trying to upgrade), unless there is a way to log more or do it in debug I do’t think theres much more to try.

Are all settings stored in the install folder structure? If I make a copy of that folder, nothing else needs backing up (service information excluded)? Just want to make sure that my previous 3.6.2 install is 100%, after all my 3.6.3 upgrade attempts, I just copied the old folder back and it seems to run fine.

You said “copied”. Do you mean overwriting the content of Openfire folder with your backup? Well, it should be fine, but i would remove that folder and then copy from a backup.

Before upgrading, I made a copy of the “openfire” structure and after my unsuccessful upgrade attempts I removed the failed upgrade structure and renamed the “old” copy. Everything seems to work.

Hi,

I have the same issue upgrading from 3.50 and/or 3.51.

Thought maybe some plugin (eg red5) is the problem and tried to uninstall them manually - no success.

After installing a second time the installation was successful but all plugins (sip, red5) disapppeard from the console (they still worked)?

I´m still happy about Openfire!!!

Any help would be apreciated.

Cheers

JoWeis

JoWeis wrote:

After installing a second time the installation was successful but all plugins (sip, red5) disapppeard from the console (they still worked)?

You can just install them again. All plugins’ settings should be saved.

wroot, thanks a lot!

I was able to install following plugins: presence, motd, search

I installed also fastpath, monitoring, sip and red5 but could not find them in the console. I tried it sometimes…

After downloading and installing the actual monitoring.jar, ALL tabs appeard in the console.

You were right, settings have been saved.

It seems to work fine!

Curious :slight_smile:

Thank you again!

JoWeis