powered by Jive Software

Upgrading from Openfire 4.0.3 to 4.1.5

Hey there,

Recently I tried to upgrade from Openfire 4.0.3 to 4,.1.5. However once I did this users could not log into Spark ( Users would get told Invalid Username and Password) and also I myself cant log into the openfire Admin Console using my account. Our openfire setup is using Active Directory.

I tried to change the config file to say setup is false and tried to setup the server from scratch again. However during setup it always seems to fail to connect to LDAP. Any Ideas or assistance?

Cheers

K-LESS

Did you run into any errors during the upgrade? make sure the launcher is closed, and the openfire service is stopped, and reinstall.
Did you verify that the account you use to connect to AD did not get locked out?
For troubleshooting. please make the base DN is the root of your domain, and for the admin dn/password use the format username@domain.local instead of the full DN.

I can confirm that I am stopping the openfire service before installing the new version. I can also verify the AD Account is not getting locked out. Can also confirm that the base DN is the root of our Domain. This same issue also happens when I try to downgrade to an older version. Its like the ldap connection gets broken. Not only can I not log in to the admin console but users are also not able to log into spark anymore either.