Uppercase - Offline problem

Dear technically smart people,

I have a weird problem with our openfire server.

First our system,

we run openfire 3.5.2 at a debian etch server. It uses ldap for users and groups. We have 347 users registered in openfire, mostly with spark, some with kopete.

For 346 users this works fine, but for one it does not.

All other users see BartH as offline, but they can spark him. He does see other users as online, but only if they were online before he logged in. This is the same with different clients. I tried to check for different settinngs in active directory but I could not find them.

But there is a difference in the User Roster screen. He is the only one with a JID with uppercase characters in it!

But he, and I guess all others logs in with lowercase in spark.

In active directory his Samaccountname is with uppercase characters, but so are the usernames of everyone else.

In the user and session screen his name is lowercase, just like everyone else.

Can anyone tell me how this happened, and even more important, how can I fix this?

I tried removing the memberof groups in active directory, waited for openfire to see this, then add him again, but still the same issue. Letting him login as BartH or barth does not make any difference.

I really don’t know where to start looking for the problem. I hope you can help.

Thanks in advance,