powered by Jive Software

URL redirect?

Ofmeet is now great, and the URL format is now much better, but how can I redirect the main http IP address directly to say, https://xx.xx.xx.xx:7443/ofmeet/r=room ?

I tried the older method on the forum - creating an index.html file - but I don’t know where to put it now or else it needs another method. Plus, changing the http-bind port from 7443 to 443 will not work any more, just gives an error.

Also a suggestion- it would be good to have a welcome page option to enter a room name rather than only via an …/ofmeet/r=xxxx URL link.

One last suggestion/question - the incorporated jitsi code now constantly phones in to google analytics, which for security and privacy, I have had to manually remove along with a hosts file which blocks script calls to google for Candy. Now Candy will not work - is it possible to incorporate scripts without relying on third parties like googleapis.com etc?

Yes. I will take a look

with openfire 3.10

the new kind of url is better

https://serveurname:7443/ofmeet is much more simplier

actually i cannot change http-bind port from 7070/7443 to 80/443 :

the admin console gives me an error if i put a port number with 2 or 3 digits it only accepts 4 digits port numbers

also ofmeet is not working if i have websocket plugin activated

changing port numbers from 7070/7443 to 80/443 is a Linux problem. You need to run openfire as a root user. Only root users can use port number under 1024

ofmeet does not need the websocket plugin. It uses it own custom websocket implementation which is tied to the webservice authentication. It automatically uses identity of the openfire user that is currently logged into the web server.

I you want a simple URL, try any of the redirection or short url services like https://goo.gl/

thank you for the answer

concerning ports :

actually i do run the openfire init script (/etc/init.d/openfire start) as root user

and i still cannot choose a port number under 1024.

have you got any idea ?

shall i change somehting in the init script ?

concerning websocket :

OK this is clear now for ofmeet plugin

i was thinking of websocket plugin to be used for mobile clients instead of bosh (but that is not strictly necessary)

i am also looking for some ios/android xmpp clients that would be using websockets efficiently

if i do this users will keep with hangouts and not openfire…

Thanks Dele, and all your hard work on Ofmeet is very much appreciated.

Somewhere on the forum a while ago you posted a method of redirection I formerly used like this:

echo ’

' > /usr/share/openfire/resources/spank/index.html

That location does not seem to work now, is there anywhere else that index.html can go for the same effect? Otherwise, the “/ofmeet” is good anyway, and I’ve figured out how to run as the root user on debian for standard 443… (see below)

To change the openfire user to root on Debian, remove the entry “–chuid openfire:openfire” in /etc/init.d/openfire and then run:

service openfire restart

thank you i replaced “–chuid openfire:openfire” by “–chuid root:root”

i now i can replace ports 7070:7443 by 80:443.

actually my adress is :

this is quite great indeed

i would enjoy too if it simply could be

copy the contents of ofmeet folder to OPENFIRE_HOME\resources\spank folder making sure that index.html is replaced with the one in ofmeet folder

you might have to look for all references to /ofmeet and change them to /

Thanks but it doesn’t seem to work… unless I am missing something? It looks like it has something to do with needing a Jetty “context handler”. I cannot find the location for a config file to set available contexts - it seems to be hard coded and compiled in somewhere. What is needed in order to redirect straight from the main IP address is apparently called the “root context”. See here: Rewrite Handler

What you might need for server-side re-direction is UrlRewriteFilter - Rewrite URL’s in Java Web Application Servers

Finally I got it working the easy way… Looks like I was almost right before, based on your earlier post, not sure where I went wrong.

Here it is for the benefit of others:

In Debian make the folder “spank” under /usr/share/openfire/resources (ie. the main “resources” folder, whatever that may be under other dists)

Create an index.html file containing:

# ("roomx" can be whatever required)

Restart openfire.

Or here is the whole thing, including defaulting to 443 instead of 7443 in Debian:

sed -i ‘s/–chuid openfire:openfire / /’ /etc/init.d/openfire

mkdir -p /usr/share/openfire/resources/spank

echo ’

' > /usr/share/openfire/resources/spank/index.html

service openfire restart

Manually set http bind to 443 from 7443 in admin panel.

Note: Or, by replacing “…URL=/ofmeet/?r=roomx” with “…URL=[https://xxx.(your](https://xxx.(your) IP/domain).xxx/ofmeet/?r=roomx” all will be automatically redirected to port 443/https.

Now typing in just the main IP address goes straight in to the ofmeet login for “roomx”.

THANKS!!! Problem solved. In my case with centos 7 i’ve only changed in /etc/init.d/openfire this:

[ -z “$OPENFIRE_USER” ] && OPENFIRE_USER=“daemon”

For that

[ -z “$OPENFIRE_USER” ] && OPENFIRE_USER=“root”

Restart service and all working perfectly

If you have issues with external connections, check IPTABLES or FIREWALLD(CENTOS7)

Only root user is allowed to use port under 1024, and openfire is run as user/group openfire/openfire.
First,
To change the openfire user to root, remove the entry “–chuid openfire:openfire” in /etc/init.d/openfire and then restart openfire service:
$sudo service openfire restart

To change admin console port, edit file: /etc/openfire/openfire.xml , and change port number to wanted value:

9090 9091

To change http-bind port, go in admin console browser page > Server settings > Section: Http-bind, change port in Http-bind settings.

This work for me.
Thanks.