powered by Jive Software

Use the python module jabber to send a message to the user

Hi all,

Now, I am using openfire4.0.3, the user is ldap. I want to upgrade openfire to 4.1.5。But I encountered some problems:

1、openfire4.0.3 is working,You can use the python module jabber to send messages to users;openfire4.1.5 is not work,

2、If the user of openfire4.1.5 is created manually (not ldap) and the plugin “Non-SASL Authentication” has been installed,You can use the python module jabber to send messages to users;the user of openfire4.1.5 is ldap, You cann’t use the python module jabber to send messages to users,Capture ip package display 401 not-authorized,Such as attachments。

Can you help me?

Thanks

What is your Openfire system property sasl.mechs currently set to? You may need to add PLAIN to that listing. I suppose another question is which python jabber library are you using?

Hi akrherz,

This link is a jabber link . http://jabberpy.sourceforge.net/#intro
This is the jabber version. jabberpy-0.5-0.tar.gz

Thanks

sasl.mechs default value(no set)

jabberpy is heavily outdated. I would recommend using aioxmpp or another actively developed python library (there are plently).

Thanks 。
now, working .openfire has upgrade to 4.2.3, use xmpppy about python modules。